[Flame][Message]After you change system language, attachment icon is not available.

VERIFIED FIXED in 2.2 S11 (1may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: wangxiaomei, Assigned: apastor)

Tracking

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: systemsfe)

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Posted video VIDEO1285.mp4
[1.Description]:
[Flame][v2.2 & v3.0][Message]Create a new message, and tap attachment icon, then slide notification to enter settings and change system language, and return to new message view, the attachment icon is not available.
Attachment: VIDEO1285.mp4 & logcat.txt
Found at: 21:14

[2.Testing Steps]: 
1. Launch message
2. Create a new message
3. Tap attachment icon
4. Slide notification bar to enter Settings
5. Change current system language to other language.
6. Return to create message view or create another message
7. Tap attachment icon

[3.Expected Result]: 
7. Select from: list should be shown.

[4.Actual Result]: 
7. There is no response after you tap attachment icon unless you reboot device.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150402002500
Gaia Revision          1ceca464053dee4a8bf10ea5abeef724d68c2ff2
Gaia Date              2015-04-01 09:49:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/427b4da96714
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.035057
Firmware Date          Thu Apr  2 03:51:09 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150402160202
Gaia Revision          62042ffcc8c6cca0f51ad23f5c2b979fc153b5a7
Gaia Date              2015-04-02 16:01:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/513265a4cbc2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.192125
Firmware Date          Thu Apr  2 19:21:37 EDT 2015
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Posted file logcat.txt
This is definitely happening in the System app.
And this is likely a blocker.
blocking-b2g: --- → 2.2?
Component: Gaia::SMS → Gaia::System::Window Mgmt
How about 2.1?
Keywords: qawanted
This issue also reproduces on Flame 2.1.

Result: The attachment option dialog does not appear when the attachment icon is pressed after changing the language.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150402115655
Gaia: 4e7d880defb83c25b49462479c02b3e64d21f421
Gecko: e76f5e7a264d
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

=================================================

The STR is not applicable in Flame 2.0. The user cannot pull down the notification tray from the dialog. Unable to reproduce on 2.0.

Environmental Variables:
Device: Flame 2.0
BuildID: 20150403080559
Gaia: 07e07b9376ac57b09810a34de25726602858e20a
Gecko: 70414e782c1f
Version: 32.0 (2.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
I tend to not block on it since its not a regression and we are not good at switching languages during runtime in general.
Does it work if the user closes the app via the task manager and re-opens it? Or is the only fix to reboot the phone?
Keywords: qawanted
Yes, the attachment icon still does not respond after closing the app through task manager and re-opening the app. The user has to restart the device to recover.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150403075758
Gaia: 16383ec2bf3ed46f893b15b3fab2892e9fadc4e7
Gecko: 90adc073cbc6
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: 2.2? → ---
Keywords: polish
(In reply to Gregor Wagner [:gwagner] from comment #5)
> I tend to not block on it since its not a regression and we are not good at
> switching languages during runtime in general.

Hi Gregor,

We find that if users skip step5 and do step 6 directly after step4, the bug can be also repro. Could you help confirm again whether it is a blocker or not? 
Thanks a lot.
blocking-b2g: --- → 2.2?
Alberto, can you take a look?
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(apastor)
Keywords: polish
Whiteboard: systemsfe
(Assignee)

Updated

4 years ago
Assignee: nobody → apastor
Flags: needinfo?(apastor)
(Assignee)

Updated

4 years ago
Attachment #8595447 - Flags: review?(alive)
Comment on attachment 8595447 [details] [review]
[gaia] albertopq:1150839-icon-attachment > mozilla-b2g:master

LGTM
Attachment #8595447 - Flags: review?(alive) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Per Comment 11,this bug has fixed on master.

According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v3.0.
See attachment: verified_v3.0.mp4.
Reproduce rate: 0/5


Device: Flame 3.0 build(Pass)
Build ID               20150426160201
Gaia Revision          b4c949cdc780893897c9b45c1adea46e2eb694ff
Gaia Date              2015-04-24 16:13:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/37d60e3b8be6
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.193323
Firmware Date          Sun Apr 26 19:33:34 EDT 2015
Bootloader             L1TC000118D0

Add verifyme keywords for v2.1&2.2 uplift.
(Assignee)

Comment 14

4 years ago
Comment on attachment 8595447 [details] [review]
[gaia] albertopq:1150839-icon-attachment > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined: Activities doesn't work anymore when opening a new app while in the activities action menu.
[Testing completed]: Added UI tests
[Risk to taking this patch] (and alternatives if risky): One liner covered by UI tests.
[String changes made]: none
Attachment #8595447 - Flags: approval-gaia-v2.2?(bbajaj)
Target Milestone: --- → 2.2 S11 (1may)
Attachment #8595447 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v2.2. 

Results: The "Select from:" list is shown after changing system language.
Reproduce rate: 0/5

Device: Flame 2.2 build(Pass)
Build ID               20150429002501
Gaia Revision          1b7aa7e60788668ed09abf76022dfa231dbe88d4
Gaia Date              2015-04-28 19:36:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d38ff4717f39
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.035717
Firmware Date          Wed Apr 29 03:57:29 EDT 2015
Bootloader             L1TC000118D0

Leaving "verifyme" keywords for v2.1 uplift.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.