l10n repacks are broken on m-c

RESOLVED FIXED

Status

Infrastructure & Operations
Buildduty
--
critical
RESOLVED FIXED
3 years ago
15 days ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=1279856&repo=mozilla-central

05:26:28 INFO - Reading from file /builds/slave/m-cen-m64-ntly-l10n-3_3-000000/build/mozilla-central/browser/locales/all-locales
05:26:28 ERROR - unable to open /builds/slave/m-cen-m64-ntly-l10n-3_3-000000/build/mozilla-central/browser/locales/all-locales: No such file or directory
05:26:28 FATAL - Uncaught exception: Traceback (most recent call last):
05:26:28 FATAL - File "/builds/slave/m-cen-m64-ntly-l10n-3_3-000000/scripts/mozharness/base/script.py", line 1288, in run
05:26:28 FATAL - self.run_action(action)
05:26:28 FATAL - File "/builds/slave/m-cen-m64-ntly-l10n-3_3-000000/scripts/mozharness/base/script.py", line 1230, in run_action
05:26:28 FATAL - self._possibly_run_method(method_name, error_if_missing=True)
05:26:28 FATAL - File "/builds/slave/m-cen-m64-ntly-l10n-3_3-000000/scripts/mozharness/base/script.py", line 1171, in _possibly_run_method
05:26:28 FATAL - return getattr(self, method_name)()
05:26:28 FATAL - File "scripts/scripts/desktop_l10n.py", line 546, in pull
05:26:28 FATAL - self.pull_locale_source()
05:26:28 FATAL - File "/builds/slave/m-cen-m64-ntly-l10n-3_3-000000/scripts/mozharness/mozilla/l10n/locales.py", line 174, in pull_locale_source
05:26:28 FATAL - locales = self.query_locales()
05:26:28 FATAL - File "/builds/slave/m-cen-m64-ntly-l10n-3_3-000000/scripts/mozharness/mozilla/l10n/locales.py", line 47, in query_locales
05:26:28 FATAL - locales = self.parse_locales_file(locales_file)
05:26:28 FATAL - File "/builds/slave/m-cen-m64-ntly-l10n-3_3-000000/scripts/mozharness/mozilla/l10n/locales.py", line 93, in parse_locales_file
05:26:28 FATAL - locales = self.read_from_file(locales_file).split()
05:26:28 FATAL - AttributeError: 'NoneType' object has no attribute 'split'
05:26:28 FATAL - Running post_fatal callback...
05:26:28 FATAL - Exiting -1
Flags: needinfo?(mgervasini)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
A mac build got past the error:

00:27:00     INFO - Changing directory to /builds/slave/m-cen-m64-ntly-l10n-1_3-000000.
00:27:00     INFO - mkdir: /builds/slave/m-cen-m64-ntly-l10n-1_3-000000/build/l10n
00:27:00     INFO - Reading from file /builds/slave/m-cen-m64-ntly-l10n-1_3-000000/build/mozilla-central/browser/locales/all-locales
00:27:00     INFO - Contents:
00:27:00     INFO -  ar
00:27:00     INFO -  ast
00:27:00     INFO -  cs
...
Blocks: 740142
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1151190
Blocks: 1151215
Flags: needinfo?(mgervasini)

Updated

15 days ago
Product: Release Engineering → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.