Link from console to source file is broken when containing the eval "//# sourceURL=..."

RESOLVED DUPLICATE of bug 1192882

Status

defect
P3
normal
RESOLVED DUPLICATE of bug 1192882
4 years ago
10 months ago

People

(Reporter: kes-kes, Unassigned)

Tracking

(Blocks 1 bug, {regression})

36 Branch
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Posted file test.html
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150328224110

Steps to reproduce:

sorry, can not attach second file. That is test.js:
function jstest() {
    console.log( 'hello' );
}

//# sourceURL=test.js

1. open test.html
2. open WebInspector (F12)
3. goto console
4. click 'Hello' button
5. You will see in console 'hello' text message and at the end of line link to source file, where this message was logged: test.js:2:4
6. click that link


Actual results:

You get new empty window with 404 page not found
Firefox can not find server: www.test.js.


Expected results:

You must open in debugger dynamically loaded test.js and move cursor to second line fourth char

Updated

4 years ago
Component: Untriaged → Developer Tools: Console
Product: Core → Firefox

Comment 1

3 years ago
The bug reproducible on Fx44b4 Win10.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All

Updated

3 years ago
Blocks: 583083
Keywords: regression
Version: 37 Branch → 36 Branch

Updated

3 years ago
Summary: link from console to source file is broken → Link from console to source file is broken when containing the eval "//# sourceURL=..."
This test case demonstrates the issue without relying on external scripts.
Flags: needinfo?(nfitzgerald)

Updated

2 years ago
Blocks: source-maps
Priority: -- → P3
I think the problem is explained in https://bugzilla.mozilla.org/show_bug.cgi?id=1192882#c2
In today's console the link isn't clickable, which is maybe an improvement over a link to nowhere,
but of course still not very good.
Closing this one as a dup.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1192882

Updated

10 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.