Reproducible crash in [@ ShConstructCompiler ] from DYLD_FORCE_FLAT_NAMESPACE and/or DYLD_INSERT_LIBRARIES

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
4 years ago
2 years ago

People

(Reporter: gss+mozilla, Unassigned)

Tracking

({crash})

37 Branch
x86
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gfx-noted, crash signature)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150326190726

Steps to reproduce:

From a shell on OS X:
1. export DYLD_INSERT_LIBRARIES=/opt/X11/lib/libXaw3d.dylib
2. export DYLD_FORCE_FLAT_NAMESPACE=1
3. /Applications/Firefox.app/Contents/MacOS/firefox-bin -no-remote -ProfileManager


Actual results:

Crash: https://crash-stats.mozilla.com/report/index/bp-2796a271-2059-4c5d-96a0-836362150403


Expected results:

Launched Firefox, opening the profile manager.
(Reporter)

Comment 1

4 years ago
There is probably no reason to allow these environment variables at all. I recommend that at the earliest possible moment in the execution (i.e. right at the beginning of main() on any *nix platform) checking for the presence of these variables and LD_PRELOAD as well and, if found, remove them from the environment and execv() again.

Updated

4 years ago
Severity: normal → critical
Crash Signature: [@ ShConstructCompiler ]
Component: Untriaged → Graphics
Keywords: crash
Product: Firefox → Core
Summary: Reproducible crash from DYLD_FORCE_FLAT_NAMESPACE and/or DYLD_INSERT_LIBRARIES → Reproducible crash in [@ ShConstructCompiler ] from DYLD_FORCE_FLAT_NAMESPACE and/or DYLD_INSERT_LIBRARIES
Whiteboard: gfx-noted
Who sets these environment variables? How did you run into this crash in the first place?
(Reporter)

Comment 3

4 years ago
(In reply to Markus Stange [:mstange] from comment #2)
> Who sets these environment variables? How did you run into this crash in the
> first place?

I'm not going to claim it's a great idea, but I've been doing it for about two decades. The Xaw (Athena Widgets) library is what xterm, among other X11 apps, uses. The Xaw3D library is a drop-in replacement that gives a different look (mainly to scrollbars and menus) and some slightly different behavior (left-clicking on the thumb on a scrollbar, for example). Since I prefer the Xaw3D look and behavior, I preload libXaw3d (on both OS X and Linux) using environment variables.
I'm closing this as invalid. The last time this crash was reported was 4 months ago with Firefox 44. It might be valid if this crash were still reproducible but it seems like too much of an edge case to support. That said I'm sure we'd accept a patch if someone wanted to write one - feel free to reopen if you want to work on this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.