[Usage][Reset Report] With SHB enabled, at the bottom of the day picker in the Usage app grey and black boxes will appear on the edges of the screen

RESOLVED DUPLICATE of bug 1146538

Status

()

Core
Panning and Zooming
RESOLVED DUPLICATE of bug 1146538
3 years ago
3 years ago

People

(Reporter: DerekH, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.5?, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing][shb-enabled], gfx-noted, URL)

Attachments

(1 attachment)

Created attachment 8588182 [details]
Cost Control Issue

Description:
If the user scrolls down to the bottom of the day selectoin picker in the reset report section of the usage app, there will be multiple graphical errors that occur when attempting to select a day. These errors include grey boxes, and black lines or highlights around the edges of the screen. Also the blue check marks will not appear, but the day will still be selected.

Prerequisite: Have software home button enabled

Repro Steps:
1) Update a Flame to 20150403010203
2) Open Usage app
3) Tap on the Gear to access settings
4) Set the Reset report to monthly> Open the Day picker
5) Scroll down to the very bottom
6) Select a day


Actual:
Check mark does not display and there are sometimes selection graphical errors like grey boxes, or black lines


Expected:
NO graphical error is seen and day is selected with a blue check mark

Environmental Variables:
Device: Flame Master
Build ID: 20150403010203 (319mb)(Kitkat)(Full Flash)
Gaia: 7969b367a7da62877c3a24a26d3cb5fda89d766c
Gecko: 70a113676b21
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Repro frequency: 10/10
See attached: Logcat, Video - https://youtu.be/esiFbgqYmfo
This issue DOES occur on Flame 2.2

Check mark does not display and there are sometimes selection graphical errors like grey boxes, or black lines

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150402002500
Gaia: 1ceca464053dee4a8bf10ea5abeef724d68c2ff2
Gecko: 427b4da96714
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


This does NOT occur on Flame 2.1

NO graphical error is seen and day is selected with a blue check mark

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150403001204
Gaia: 4e7d880defb83c25b49462479c02b3e64d21f421
Gecko: e76f5e7a264d
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][shb-enabled]
[Blocking Requested - why for this release]:
Regression of a supported feature, since it's SHB starting with 3.0?.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
QA Contact: pcheng
Whiteboard: [3.0-Daily-Testing][shb-enabled] → [3.0-Daily-Testing][shb-enabled], gfx-noted
QA Contact: pcheng → ychung
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: regressionwindow-wanted
QA Contact: ychung
Resolution: --- → DUPLICATE
Duplicate of bug: 1146538
This doesn't sound like a dupe of bug 1146538. It might be a dupe of bug 1151306 (like bug 1151094). And it doesn't involve low-resolution painting, so it's not a dupe of bug 1151071.
You need to log in before you can comment on or make changes to this bug.