Closed Bug 1151172 Opened 7 years ago Closed 7 years ago

"test_marketplace_search_and_install_app" is failing on b2g v2.2

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.2 affected, b2g-master unaffected)

RESOLVED DUPLICATE of bug 1136791
Tracking Status
b2g-v2.2 --- affected
b2g-master --- unaffected

People

(Reporter: pmathur, Unassigned)

References

()

Details

Attachments

(1 file)

Attached file Smoketest report
[Description]
test_marketplace_search_and_install_app.py fails

[Steps to Reproduce]
Run the test_marketplace_search_and_install_app.py

Traceback (most recent call last):
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g37_v2_2-0.1-py2.7.egg/marionette/marionette_test.py", line 268, in run
    testMethod()
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/marketplace/test_marketplace_packaged_app.py", line 28, in test_search_and_install_app
    marketplace.search(self.app_search)
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/gaiatest/apps/marketplace/app.py", line 53, in search
    search_box.send_keys(term)
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g37_v2_2-0.1-py2.7.egg/marionette/marionette.py", line 113, in send_keys
    return self.marionette._send_message('sendKeysToElement', 'ok', id=self.id, value=typing)
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g37_v2_2-0.1-py2.7.egg/marionette/decorators.py", line 36, in _
    return func(*args, **kwargs)
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g37_v2_2-0.1-py2.7.egg/marionette/marionette.py", line 615, in _send_message
    "Connection timed out", status=errors.ErrorCodes.TIMEOUT)
TimeoutException: TimeoutException: Connection timed out


Most recent errors/exceptions are:
04-04 04:58:28.280 W/GeckoConsole(27832): [JavaScript Error: "A promise chain failed to handle a rejection. Did you forget to '.catch', or did you forget to 'return'?04-04 04:58:28.280 W/GeckoConsole(27832): Full Stack: JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: PendingErrors.register :: line 16504-04 04:58:30.920 W/Marketplace(28312): [JavaScript Error: "uncaught exception: [object Object]"]
The B2G process has restarted after crashing during  the tests so Marionette can't respond due to either a Gecko, Gaia or Marionette error. Above, the 5 most recent errors are listed. Check logcat for all errors if these errors are not the cause of the failure.

Traceback (most recent call last):
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g37_v2_2-0.1-py2.7.egg/marionette/marionette_test.py", line 296, in run
    self.tearDown()
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 984, in tearDown
    MarionetteTestCase.tearDown(self)
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g37_v2_2-0.1-py2.7.egg/marionette/marionette_test.py", line 516, in tearDown
    (self.filepath.replace('\\', '\\\\'), self.methodName))
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g37_v2_2-0.1-py2.7.egg/marionette/marionette.py", line 1293, in execute_script
    filename=os.path.basename(frame[0]))
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g37_v2_2-0.1-py2.7.egg/marionette/decorators.py", line 36, in _
    return func(*args, **kwargs)
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g37_v2_2-0.1-py2.7.egg/marionette/marionette.py", line 634, in _send_message
    self._handle_error(response)
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g37_v2_2-0.1-py2.7.egg/marionette/marionette.py", line 663, in _handle_error
    "Malformed packet, expected key 'error' to be a dict: %s" % response)
MarionetteException: MarionetteException: Malformed packet, expected key 'error' to be a dict: {u'message': u'this.curBrowser is null', u'error': u"error occurred while processing 'executeScript"}

[Build info]
Device firmware (base) 	L1TC100118D0
Device firmware (date) 	03 Apr 2015 15:39:58
Device firmware (incremental) 	eng.cltbld.20150403.033949
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	03 Apr 2015 12:13:03
Gaia revision 	022eeb91197b
Gecko build 	20150403002503
Gecko revision 	77fdc6fbcae9
Gecko version 	37.0
Geo, could you please investigate on a preliminary basis?
Flags: needinfo?(gmealer)
Flags: needinfo?(echang)
I can't reproduce here, locally, using:
Build ID               20150404010205
Gaia Revision          16383ec2bf3ed46f893b15b3fab2892e9fadc4e7
Gaia Date              2015-04-03 06:14:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/90adc073cbc6
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150403.042432
Firmware Date          Fri Apr  3 04:24:41 EDT 2015
Bootloader             L1TC000118D0

I assume this was an intermittent failure?
Oh, sorry, I didn't see this is on v2.2.

Now tested, using:
Build ID               20150404002503
Gaia Revision          a6351e1197d54f8624523c2db9ba1418f2aa046f
Gaia Date              2015-04-03 22:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2247e3c01cc1
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  65
Firmware Date          Mon Dec 15 18:51:29 CST 2014
Bootloader             L1TC000118D0


(gaia-py-v2.2)mwargers:gaia_clean mwargers$ adb forward tcp:2828 tcp:2828 && DEVICE_DEBUG=1 && gaiatest --address=localhost:2828  --testvars /Users/mwargers/B2G/testvars_home.json --gecko-log=/Users/mwargers/B2G/gecko.log --restart --log-mach=bug1099985.log --log-mach-level=debug tests/python/gaia-ui-tests/gaiatest/tests/functional/marketplace/test_marketplace_packaged_app.py
Results will not be posted to Treeherder. Please set the following environment variables to enable Treeherder reports: TREEHERDER_KEY, TREEHERDER_SECRET
starting httpd
running webserver on http://172.16.128.1:50796/
mozversion Unable to find system/sources.xml
mozversion application_buildid: 20150404002503
mozversion application_changeset: 2247e3c01cc1
mozversion application_display_name: B2G
mozversion application_id: {3c2e2abc-06d4-11e1-ac3b-374f68613e61}
mozversion application_name: B2G
mozversion application_remotingname: b2g
mozversion application_repository: https://hg.mozilla.org/releases/mozilla-b2g37_v2_2
mozversion application_vendor: Mozilla
mozversion application_version: 37.0
mozversion device_firmware_date: 1418640689
mozversion device_firmware_version_base: L1TC000118D0
mozversion device_firmware_version_incremental: 65
mozversion device_firmware_version_release: 4.4.2
mozversion device_id: flame
mozversion gaia_changeset: a6351e1197d54f8624523c2db9ba1418f2aa046f
mozversion gaia_date: 1428098801
mozversion platform_buildid: 20150404002503
mozversion platform_changeset: 2247e3c01cc1
mozversion platform_repository: https://hg.mozilla.org/releases/mozilla-b2g37_v2_2
mozversion platform_version: 37.0
SUITE-START | Running 1 tests
TEST-START | test_marketplace_packaged_app.py TestSearchMarketplaceAndInstallApp.test_search_and_install_app
TEST-PASS | test_marketplace_packaged_app.py TestSearchMarketplaceAndInstallApp.test_search_and_install_app | took 103769ms

SUMMARY
-------
passed: 1
failed: 0
todo: 0
SUITE-END | took 104s


So it's still passing for me, locally.

Is this failing every time or was this a one-time failure?
Flags: needinfo?(pmathur)
Talked to Parul and she confirmed that this isn't failing in the product. Since our team in the US doesn't have the specific setup or background in 2.2, I think this is best left for Taipei's return.
Flags: needinfo?(gmealer)
Flags: needinfo?(echang) → needinfo?(ashiue)
Is this the tests that exist at https://github.com/mozilla/marketplace-tests-gaia? If so, I wasn't aware these were being run on anything other than v2.0. In fact, this repository is pinned to gaiatest-v2.0, which is using a release of the Marionette client based on the v2.0 branch.

Last week v2.2 was also updated to use a branched version of the Marionette client, which may have caused a regression. The trace looks like it may be a crash though, similar to bug 1137653. The teardown trace issue would likely be cleaned up by uplifting the following patches to the v2.2 branch, but this wouldn't solve the crash/exception:

https://hg.mozilla.org/mozilla-central/rev/7a78ca49e38e
https://hg.mozilla.org/mozilla-central/rev/e2358ee2e4c8
From reading the original comment I strongly doubt this is related to the marketplace-tests-gaia repository, so updating the summary.
Summary: [marketplace-tests-gaia] "test_marketplace_search_and_install_app" is failing on b2g v2.2 → "test_marketplace_search_and_install_app" is failing on b2g v2.2
This bug is dup of Bug 1136791.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(ashiue)
Resolution: --- → DUPLICATE
Duplicate of bug: 1136791
You need to log in before you can comment on or make changes to this bug.