[v2.2] Investigate test_keyboard_predictive_key.py failure

RESOLVED DUPLICATE of bug 1121978

Status

RESOLVED DUPLICATE of bug 1121978
3 years ago
3 years ago

People

(Reporter: pmathur, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

[Smoketest report]
http://mozilla-twqa.github.io/Gaiatest-Reports/2015/04/20150403002503-v2.2-flame/non-smoketest.html

[Description]
test_keyboard_predictive_key.py fails

[Steps to Reproduce]
Run the test_keyboard_predictive_key.py

Traceback (most recent call last):
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.non-smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g37_v2_2-0.1-py2.7.egg/marionette/marionette_test.py", line 268, in run
    testMethod()
  File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.non-smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/keyboard/test_keyboard_predictive_key.py", line 64, in test_keyboard_predictive_key
    self.assertEqual(keyboard_page.text_input, 'keyboard Tea he ')
AssertionError: u'keyboard Tea ye ' != 'keyboard Tea he '

[Build info]
Device firmware (base) 	L1TC100118D0
Device firmware (date) 	03 Apr 2015 15:39:58
Device firmware (incremental) 	eng.cltbld.20150403.033949
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	03 Apr 2015 12:13:03
Gaia revision 	022eeb91197b
Gecko build 	20150403002503
Gecko revision 	77fdc6fbcae9
Gecko version 	37.0
Geo, could you please investigate on a preliminary basis?
Flags: needinfo?(gmealer)
Flags: needinfo?(echang)
This is bug 1121978.

In bug 1121978, comment 20, I made a pull request that might have made things better. I don't think that landed on v2.2. It might be worth the effort.

Bug 1139976 might also fix this issue (by using better words).
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1121978
Flags: needinfo?(gmealer)
Flags: needinfo?(echang)
Largely the same story as https://bugzilla.mozilla.org/show_bug.cgi?id=1151172#c4 -- since it's not in the product, I'd rather leave it to Taipei to chase further. Looks like Martijn probably has the right of it in comment 2, though.
You need to log in before you can comment on or make changes to this bug.