Videos (Youtube) do not play if about:config media.mediasource.enabled is "true" (FF37.0.1)

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: euronymous2, Unassigned)

Tracking

37 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150402191859

Steps to reproduce:

Nothing. Just updated to 37.0.1.


Actual results:

YT-Videos stopped working. No plugin is active.


Expected results:

Videos should play in HTML5. Switching media.mediasource to "false" resolves it. Not a permanent solution I guess.
(Reporter)

Comment 1

3 years ago
Hardware acc is OFF and GPU is NVidia GTX 760, driver ver 344.75.

Comment 2

3 years ago
Could you test YT videos with a fresh profile, please.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(euronymous2)

Updated

3 years ago
Component: Untriaged → Video/Audio
Product: Firefox → Core
(Reporter)

Comment 3

3 years ago
Done. With fresh profile YT videos work. I usually have no plugins installed and as addons "adblock plus,noscript,flash video downloader,proxtube. 

I found the reason: It's noscript. It blocks mediasource (that's new). One time disabling NS and re-enabling + allowing mediasource as script does it.

You can mark this bug as solved if you wish.
Flags: needinfo?(euronymous2)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.