If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

pdf is not rendering numeric characters on OSX

RESOLVED FIXED in Firefox 42

Status

()

Firefox
PDF Viewer
P3
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: c.saunders322, Unassigned)

Tracking

37 Branch
Firefox 42
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/6171)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8588312 [details]
99d7ae_73a819c4626c46069e659ea17559e544.pdf

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150326190726

Steps to reproduce:

Download PDF and view it in Firefox

View attached PDF in Firefox


Actual results:

Areas of text that should contain numbers are displaying incorrect glyphs.

One example: "Win up to $<unreadable glyphs> in cash prizes"


Expected results:

The PDF should have rendered the numbers correctly and read "Win up to $500 in cash prizes"

Comment 1

3 years ago
Created attachment 8588343 [details]
Capture d'écran 2015-04-04 à 21.03.43.png

WFM with FF37 on Win 7.

Could you attach a screenshot, please.

Updated

3 years ago
Flags: needinfo?(c.saunders322)

Updated

3 years ago
Component: Untriaged → PDF Viewer
(Reporter)

Comment 2

3 years ago
Created attachment 8588362 [details]
6yx4gewg0v7g.png

Rendering errors on Mac OS 10.10.2 running Firefox 37.0
Flags: needinfo?(c.saunders322)

Comment 3

3 years ago
Do you know if it worked with previous versions of Firefox?
Summary: pdf is not rendering numeric characters → pdf is not rendering numeric characters on OSX
(Reporter)

Comment 4

3 years ago
I do not.
Likely the characters fall in some range that we need to not map glyphs too.
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion]
Reproduced in Nightly 40.0a1 2015-04-08 under Mac OS X 10.9.5 in both e10s and non-e10s windows.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

3 years ago
Is it a regression?

Updated

2 years ago
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion] → [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/6171
Depends on: 1182228
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42

Updated

2 years ago
Duplicate of this bug: 1203587
You need to log in before you can comment on or make changes to this bug.