Intermittent testFlingCorrectness | Pixel at 0, 0 - Color rgba(255,255,255,255) not close enough to expected rgb(0,0,0)

RESOLVED FIXED in Firefox 39

Status

()

Firefox for Android
Testing
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: philor, Assigned: gbrown)

Tracking

({intermittent-failure})

Trunk
Firefox 40
ARM
Android
intermittent-failure
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox38 unaffected, firefox39 fixed, firefox40 fixed, firefox-esr31 unaffected)

Details

Attachments

(1 attachment)

Comment hidden (empty)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 4

3 years ago
See also 767214 and perhaps 1009290. Screenshots show the progress bar in-progress, suggesting that page load has not completed. A side-effect of bug 923109?
Assignee: nobody → gbrown
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 7

3 years ago
Created attachment 8590829 [details] [diff] [review]
use loadUrlAndWait more

I should have thought more about https://bugzilla.mozilla.org/show_bug.cgi?id=923109#c7. Seeing these failures, I notice that blockForEvent(DOMContentLoaded) will wait for up to 90 seconds, while the title and url verifications have much shorter waits.

This patch updates all of my previously introduced loadUrl's to loadUrlAndWait.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=b2afbb42d75a
Attachment #8590829 - Flags: review?(margaret.leibovic)

Updated

3 years ago
Attachment #8590829 - Flags: review?(margaret.leibovic) → review+
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/19dcfac36d94
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox40: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
status-firefox38: --- → unaffected
status-firefox39: --- → affected
status-firefox-esr31: --- → unaffected
https://hg.mozilla.org/releases/mozilla-aurora/rev/15230953af6e
status-firefox39: affected → fixed
Flags: in-testsuite+
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1009290
You need to log in before you can comment on or make changes to this bug.