Compose Window: 'From' menulist (msgIdentity) menu items have incorrect values

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: dw-dev, Unassigned)

Tracking

38 Branch
x86_64
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

I am the author of the Account Colors add-on.

With Thunderbird 38.0b1, Account Colors no longer colors the message header in the Compose Window, because the 'From' menulist (msgIdentity) menu items have incorrect values.




Actual results:

Let:  menulist = document.getElementById("msgIdentity");

then:  menulist.selectedItem.value

has a value such as:  "dw-test1 <dw-test1@live.co.uk>"

and is the same value as:  menulist.selectedItem.label


Expected results:

Let:  menulist = document.getElementById("msgIdentity");

then:  menulist.selectedItem.value

should have a value such as:  "id1"
This is expected I think, see bug 1135610 (and bug 87987). 
You can use the identitykey attr instead now.
Blocks: 1135610
(Reporter)

Comment 2

4 years ago
Thanks - I had missed that.

My Account Color add-on works fine using the new "identitykey" attribute.

This bug can be closed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.