Crash opening a newsserver

VERIFIED WORKSFORME

Status

MailNews Core
Networking: NNTP
P2
critical
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: scottputterman, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash})

Trunk
Future
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Using 12/13 build on NT 4.0

I clicked on a newsserver (news.mozilla.org) twisty to display the newsgroups. 
I crashed before it opened up.  I couldn't reproduce it.

the talkback id is 443514.  Here's the top of the stack:

MSVCRT.dll + 0x10752 (0x78010752)
copy_string [..\..\dist\include\string\nsAlgorithm.h, line 92]
ToNewCString [d:\builds\seamonkey\mozilla\string\src\nsReadableUtils.cpp, line 242]
nsNNTPProtocol::LoadUrl
[d:\builds\seamonkey\mozilla\mailnews\news\src\nsNNTPProtocol.cpp, line 1073]
nsNNTPProtocol::LoadNewsUrl
[d:\builds\seamonkey\mozilla\mailnews\news\src\nsNNTPProtocol.cpp, line 659]
nsNntpService::RunNewsUrl
[d:\builds\seamonkey\mozilla\mailnews\news\src\nsNntpService.cpp, line 1161]
nsNntpService::UpdateCounts
[d:\builds\seamonkey\mozilla\mailnews\news\src\nsNntpService.cpp, line 1514]
nsNntpIncomingServer::PerformExpand
[d:\builds\seamonkey\mozilla\mailnews\news\src\nsNntpIncomingServer.cpp, line 618]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 106]
(Reporter)

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: crash

Updated

17 years ago
Severity: normal → critical
Scott, any chance you remember how many groups it was performing biff on when
you opened it up?
(Reporter)

Comment 2

17 years ago
I have 11 groups on that server.  I haven't been able to reproduce this.  I've
opened it up a number of times since.
(Reporter)

Comment 3

17 years ago
I just hit this crash again.  I clicked on the twisty for news.mozilla.org and I
crashed with the same stack.  Talback ID:  699038
Keywords: nsbeta1+
Priority: -- → P2
Target Milestone: --- → mozilla0.9.8
(Reporter)

Comment 4

17 years ago
This just happened to me again.  See Talkback ID: 1211752

This time, instead of opening a twisty, I just selected a newsgroup in an
already open server (n.p.m.mail-news).  Before it started loading anything it
crashed.
I haven't had any luck reproducing this yet.

putterman, could you turn on nntp protocol logging?  I have a feeling that 
command specific data [determined by nsNNTPProtocol::ParseURL()] is bogus, and 
that is causing the crash.

for how to set up nntp logging, see
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#nntp

then, the next time you crash, can you attach your log?
(Reporter)

Comment 6

17 years ago
I've turned it on.  I seem to be hitting this every week or two so if I hit it
again, I'll attach it.
moving out to 0.9.9, until we get more data.
Target Milestone: mozilla0.9.8 → mozilla0.9.9
(Reporter)

Comment 8

16 years ago
I haven't hit this in a while and it doesn't seem like anyone else is either. So
I'm moving this out until I get more data.
Keywords: nsbeta1+ → nsbeta1-
Target Milestone: mozilla0.9.9 → Future

Comment 9

16 years ago
I'd rather see this closed and a new bug opened if it ever happens again...

Comment 10

16 years ago
I've been seeing the opposite problem, about five times in the past week, using
both trunk and branch builds. This is OS/2 and I get no trap. Mozilla just dies
dead, browser and all. It happens randomly. I cannot reproduce at will. What
crashes it is LMB click closing the news.atlantic.net folder from which I had
been reading usually in netscape.public.mozilla.os2, and which contains IIRC 18
subscribed groups. Originally there were ~73 groups subscribed in N4 and
migrated. After migration I unsuscribed the remainder via the right click menu
on each. about half of these 18 group folders have never yet been opened in
Mozilla. Current build 2002051816 branch.

Comment 11

14 years ago
Felix, scottputterman:
now it's almost two years later... have you encountered this during the recent
weeks/months?
 

Comment 12

14 years ago
I haven't seen this in a long time, but I don't use mailnews for news much. N4
still works better due to bug 21344 in particular and bug 176238 in general.

Comment 13

14 years ago
I cannot reproduce this crash with Mozilla 1.7 beta and no one's seen in in a
long time. I cannot find any other crashers reported in Bugzilla for this
problem. Please reopen if you see this again. 
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
I also haven't seen this, and I use NTTP daily in Seamonkey.

Build 2004-06-07-09, Windows XP.
Status: RESOLVED → VERIFIED
NNTP, of course (2:06 am doesn't lend itself well to great typing skills)
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.