copy unique selector on identifiers with special characters is lacking backslashes

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
2 months ago

People

(Reporter: mozilla, Unassigned)

Tracking

36 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150321180055

Steps to reproduce:

I select the unique identifier in firefox developer mode on the date span in "Firmware 0.6 January 07, 2015 " on http://luebeck.freifunk.net/2015/01/07/announce-0.6.html



Actual results:

I get: 

  heading > div:nth-child(1) > div:nth-child(1) > h1:nth-child(1) > span="postdate":nth-child(1)


Expected results:

This doesn't work, because firefox doesn't add backslashes on `"` and `=`

It would work though, if I use backslashes, so the easyest way to access only that falsy span is to add this: 

h1 > span\=\"postdate\":nth-child(1) {
  font-size: 0.3em;
}

see also: stackoverflow.com/questions/29424101/modify-css-for-a-span-with-equalsign

Updated

3 years ago
Component: Untriaged → Developer Tools: Inspector
As mentioned on stackoverflow, the HTML used here is invalid. Moreover the original page is no longer using this structure, and no other developer tool attempts to support this syntax. 

WONTFIX in my opinion, please reopen if you feel another way.

Inspector bug triage. Filter on CLIMBING SHOES.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.