Opening Camera from empty Video app shows unlocalized/English 'Video-Mode' which is the string entity id and not the value

RESOLVED DUPLICATE of bug 1138718

Status

Firefox OS
Gaia::Camera
RESOLVED DUPLICATE of bug 1138718
3 years ago
3 years ago

People

(Reporter: aryx, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected)

Details

B2G 2.2 20150405002503 on Flame (v18D base image)

Opening the Camera from empty Video app shows the unlocalized 'Video-Mode' which is the string entity id and not the value.

Steps to reproduce:
1. Set the phone to a non-English locale (Settings > Language; tested with French and German).
2. Terminate running Video and Camera apps from the list of running apps (long pressing Home button).
3. Open the Video app.
4. Delete existing videos.
5. Now the Video app should tell you that there aren't any videos and that you can record video with the Camera app. Tap the button to open the Camera app.

Actual result:
Camera app opened with text 'Video-Mode' in the center.

Expected result:
A) Localized version of 'Video-Mode' shown.
B) For English, 'Video Mode' should be shown, see https://github.com/mozilla-b2g/gaia/blob/master/apps/camera/locales/camera.en-US.properties#L84
Video-Mode = Video Mode

Comment 1

3 years ago
David or Russ

Could you please check whats going on here. 

Thanks
Hema
Flags: needinfo?(rnicoletti)
Flags: needinfo?(dflanagan)
Its a camera bug, not a Video app bug, so we may need one of the camera peers to look at it.

It is easy to reproduce, but only seems to occur in this one special case where we're invoking the camera app, via activity, to record videos. In all other cases where the camera is invoked, it defaults to still photos and does not display any string.

I assume that what is happening is that the camera app is not waiting for the locale files to be loaded (to avoid slowing down startup time) and is then trying to display a message before that message can be localized. Since the localized string is not available, it ends up just displaying the string id instead.

Waiting for the locale to be loaded seems like the wrong way to fix this because it is likely to cause a startup time regression.

It seems to me that the real bug is that the camera displays anything. The "Video Mode" message is normally displayed when the user switches from photo to video mode.  It seems wrong to display the message when the camera is invoked in video mode.  So it seems to me that the right fix is to prevent the message from being displayed in the first place.

I don't think that this is something that should be 2.2+ because it occurs rarely. On the other hand, it might occur on one of the user's very first interactions with the phone, so we really should fix it if we can. So I don't support blocking on this, but I would strongly support the uplift of a simple fix.

Diego: is this something you can take?
Flags: needinfo?(rnicoletti)
Flags: needinfo?(dmarcos)
Flags: needinfo?(dflanagan)
I have no bandwidth at the moment. I'm dealing with a P1 blocker. Wilson or Justin might have bandwidth
Flags: needinfo?(wilsonpage)
Flags: needinfo?(jdarcangelo)
Flags: needinfo?(dmarcos)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(wilsonpage)
Resolution: --- → DUPLICATE
Duplicate of bug: 1138718
Flags: needinfo?(jdarcangelo)

Updated

3 years ago
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.