Intermittent test_namednodemapsetnameditemns04.html | application crashed [@ 0x10b948f81][@ EnterBaseline][@ xpc::DOMXrayTraits::resolveOwnProperty(JSContext*, js::Wrapper const&, JS::Handle<JSObject*>, JS::Handle<JSObject*>, JS::Handle<jsid>, JS::Mutabl]

RESOLVED DUPLICATE of bug 967463

Status

()

Core
JavaScript Engine: JIT
RESOLVED DUPLICATE of bug 967463
3 years ago
3 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Trunk
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox40 affected)

Details

(Reporter)

Description

3 years ago
14:07:00 INFO - 4459 INFO TEST-START | dom/tests/mochitest/dom-level2-core/test_namednodemapsetnameditemns04.html
14:07:00 INFO - ++DOMWINDOW == 165 (0x127487400) [pid = 4904] [serial = 6885] [outer = 0x12e20c800]
14:07:00 INFO - [Parent 4904] WARNING: Performance Entry buffer size maximum reached!: file /builds/slave/fx-team-m64-d-0000000000000000/build/src/dom/base/nsPerformance.cpp, line 593
14:07:00 INFO - ++DOCSHELL 0x14eb34800 == 22 [pid = 4904] [id = 1771]
14:07:00 INFO - ++DOMWINDOW == 166 (0x12fac6800) [pid = 4904] [serial = 6886] [outer = 0x0]
14:07:00 INFO - [Parent 4904] WARNING: Subdocument container has no frame: file /builds/slave/fx-team-m64-d-0000000000000000/build/src/layout/base/nsDocumentViewer.cpp, line 2511
14:07:00 INFO - ++DOMWINDOW == 167 (0x12facb400) [pid = 4904] [serial = 6887] [outer = 0x12fac6800]
14:07:00 INFO - [Parent 4904] WARNING: NS_ENSURE_SUCCESS(EnsureScriptEnvironment(), nullptr) failed with result 0x80040111: file /builds/slave/fx-team-m64-d-0000000000000000/build/src/docshell/base/nsDocShell.cpp, line 4597
14:07:01 INFO - [Parent 4904] WARNING: Failed to open external DTD: publicId "STAFF" systemId "staffNS.dtd" base "http://mochi.test:8888/tests/dom/tests/mochitest/dom-level2-core/files/staffNS.xml" URL "resource://gre/res/dtd/staffNS.dtd": file /builds/slave/fx-team-m64-d-0000000000000000/build/src/parser/htmlparser/nsExpatDriver.cpp, line 703
14:07:01 INFO - 4460 INFO TEST-OK | dom/tests/mochitest/dom-level2-core/test_namednodemapsetnameditemns04.html | took 260ms
14:07:01 INFO - TEST-INFO | Main app process: killed by SIGHUP
14:07:01 WARNING - TEST-UNEXPECTED-FAIL | dom/tests/mochitest/dom-level2-core/test_namednodemapsetnameditemns04.html | application terminated with exit code 1
14:07:01 INFO - runtests.py | Application ran for: 0:33:55.910996
14:07:01 INFO - zombiecheck | Reading PID log: /var/folders/po/poKNUmtfEvqT9YYoM8L4rU+++-k/-Tmp-/tmpegheyHpidlog
14:07:26 INFO - mozcrash Saved minidump as /builds/slave/test/build/blobber_upload_dir/9F5FBDAE-FFCA-4C96-B85E-16B3B36F9D4C.dmp
14:07:26 INFO - mozcrash Saved app info as /builds/slave/test/build/blobber_upload_dir/9F5FBDAE-FFCA-4C96-B85E-16B3B36F9D4C.extra
14:07:26 WARNING - PROCESS-CRASH | dom/tests/mochitest/dom-level2-core/test_namednodemapsetnameditemns04.html | application crashed [@ 0x10b948f81]
14:07:26 INFO - Crash dump filename: /var/folders/po/poKNUmtfEvqT9YYoM8L4rU+++-k/-Tmp-/tmpgUnMHx.mozrunner/minidumps/9F5FBDAE-FFCA-4C96-B85E-16B3B36F9D4C.dmp
14:07:26 INFO - Operating system: Mac OS X
14:07:26 INFO - 10.6.8 10K549
14:07:26 INFO - CPU: amd64
14:07:26 INFO - family 6 model 23 stepping 10
14:07:26 INFO - 2 CPUs
14:07:26 INFO - Crash reason: EXC_BAD_ACCESS / 0x0000000d
14:07:26 INFO - Crash address: 0x0
14:07:26 INFO - Thread 0 (crashed)
14:07:26 INFO - 0 0x10b948f81
14:07:26 INFO - rbx = 0x0000000160fed790 r12 = 0x0000000000000000
14:07:26 INFO - r13 = 0x000000010ad360b8 r14 = 0x000000012c13ef40
14:07:26 INFO - r15 = 0x000000010ac1cd00 rip = 0x000000010b948f81
14:07:26 INFO - rsp = 0x00007fff5fbf9950 rbp = 0x00007fff5fbf99a8
14:07:26 INFO - Found by: given as instruction pointer in context
14:07:26 INFO - 1 XUL!EnterBaseline [BaselineJIT.cpp:61da0ee2db1f : 124 + 0xb]
14:07:26 INFO - rip = 0x00000001053c32ad rsp = 0x00007fff5fbf9a20
14:07:26 INFO - Found by: stack scanning
14:07:26 INFO - 2 XUL!xpc::DOMXrayTraits::resolveOwnProperty(JSContext*, js::Wrapper const&, JS::Handle<JSObject*>, JS::Handle<JSObject*>, JS::Handle<jsid>, JS::MutableHandle<JSPropertyDescriptor>) [XrayWrapper.cpp:61da0ee2db1f : 1537 + 0x11]
14:07:26 INFO - rip = 0x0000000102479801 rsp = 0x00007fff5fbf9ad0
14:07:26 INFO - Found by: stack scanning
14:07:26 INFO - 3 XUL!xpc::XrayWrapper<js::CrossCompartmentWrapper, xpc::DOMXrayTraits>::getOwnPropertyDescriptor(JSContext*, JS::Handle<JSObject*>, JS::Handle<jsid>, JS::MutableHandle<JSPropertyDescriptor>) const [RootingAPI.h:61da0ee2db1f : 771 + 0x4]
14:07:26 INFO - rip = 0x000000010247fd15 rsp = 0x00007fff5fbf9b60
14:07:26 INFO - Found by: stack scanning
14:07:26 INFO - 4 XUL!js::jit::Compile [IonOptimizationLevels.cpp:61da0ee2db1f : 155 + 0x11]
14:07:26 INFO - rip = 0x0000000105444c5a rsp = 0x00007fff5fbf9bf0
14:07:26 INFO - Found by: stack scanning
14:07:26 INFO - 5 XUL!js::Shape::isBigEnoughForAShapeTable() [Shape.h:61da0ee2db1f : 983 + 0x7]
14:07:26 INFO - rip = 0x00000001052828b8 rsp = 0x00007fff5fbf9c70
14:07:26 INFO - Found by: stack scanning
14:07:26 INFO - 6 XUL!JSRuntime::handleInterrupt(JSContext*) [jscntxt.h:61da0ee2db1f : 245 + 0x2]
14:07:26 INFO - rip = 0x0000000105212b01 rsp = 0x00007fff5fbf9c80
14:07:26 INFO - Found by: stack scanning
14:07:26 INFO - 7 XUL!js::Shape::search(js::ExclusiveContext*, js::Shape*, jsid, js::ShapeTable::Entry**, bool) [Shape-inl.h:61da0ee2db1f : 74 + 0x7]
14:07:26 INFO - rip = 0x000000010523b008 rsp = 0x00007fff5fbf9ca0
14:07:26 INFO - Found by: stack scanning
14:07:26 INFO - 8 libnss3.dylib!PR_GetCurrentThread [ptthread.c:61da0ee2db1f : 651 + 0xb]
14:07:26 INFO - rip = 0x0000000101b27cb5 rsp = 0x00007fff5fbf9cc0
14:07:26 INFO - Found by: stack scanning
14:07:26 INFO - 9 XUL!js::jit::EnterBaselineMethod(JSContext*, js::RunState&) [BaselineJIT.cpp:61da0ee2db1f : 156 + 0x7]
14:07:26 INFO - rip = 0x00000001053c3061 rsp = 0x00007fff5fbf9d10
14:07:26 INFO - Found by: stack scanning
14:07:26 INFO - 10 XUL!js::TypeScript::SetArgument(JSContext*, JSScript*, unsigned int, js::TypeSet::Type) [TypeInference-inl.h:61da0ee2db1f : 650 + 0xa]
14:07:26 INFO - rip = 0x00000001052f8982 rsp = 0x00007fff5fbf9d60
14:07:26 INFO - Found by: stack scanning
Comment hidden (Treeherder Robot)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: crash, intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 967463
You need to log in before you can comment on or make changes to this bug.