shutdownhang signatures can be >255 characters

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: kairo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
The signature shortening for shutdownhangs doesn't seem to take the leading "shutdownhang | " into account.

An example that shows a signature >255 characters is bp-4a3b00b9-91a9-4459-81c9-2f1922150401
[@ shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | PR_Wait | mozilla::ReentrantMonitor::Wait(unsigned int) | nsThread::ProcessNextEvent(bool, bool*) | NS_ProcessNextEvent(nsIThread*, bool) | mozilla::dom::ContentParent::Observe(nsISupports*, char const*, wc... ]

Note that my jobs getting things out of the PostgreSQL DB list those crashes as "shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | PR_Wait | mozilla::ReentrantMonitor::Wait(unsigned int) | nsThread::ProcessNextEvent(bool, bool*) | NS_ProcessNextEvent(nsIThread*, bool) | mozilla::dom::ContentParent::Observe(nsISupports*, cha" which is cut at 255 chracters.

So when you go to https://crash-stats.mozilla.com/report/list?signature=shutdownhang%20%7C%20WaitForSingleObjectEx%20%7C%20WaitForSingleObject%20%7C%20PR_Wait%20%7C%20mozilla%3A%3AReentrantMonitor%3A%3AWait%28unsigned%20int%29%20%7C%20nsThread%3A%3AProcessNextEvent%28bool%2C%20bool%2A%29%20%7C%20NS_ProcessNextEvent%28nsIThread%2A%2C%20bool%29%20%7C%20mozilla%3A%3Adom%3A%3AContentParent%3A%3AObserve%28nsISupports%2A%2C%20cha and call up any report from the "reports" table, it will have a longer signature stated than what that report/list is for.
Adrian, are we going to re-land the Elasticsearch-backed /report/list soon? If so I think it would fix this problem right (as this limit is being imposed by the varchar(256) on the signature column of reports table right?)

KaiRo, I'm not sure if we can fix this in the existing reports table, but you should be able to use processed_crashes now, or reports_clean when we change it so it's populated by processed_crashes instead of reports.
Flags: needinfo?(adrian)
(Reporter)

Comment 2

4 years ago
The bug is that we even create signatures that are longer than 255 characters, and it's a processor bug. Everything else is just a symptom of that bug. The largest issue we see actually is that we are unable to connect a bug to that signature at all, which would not change at all by pointing report/list to ES, from what I understand.
KaiRo is right here, switching to SuperSearch for report/list/ (which, yes, will happen again soon) won't solve the root cause of this problem.
Flags: needinfo?(adrian)

Comment 4

4 years ago
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/3f5cbd246957c2f480fb94a59119e11e1433c090
Fix bug 1151436. Handle signatures over 255 chars correctly.

https://github.com/mozilla/socorro/commit/e23e941ee393c61bbf0cf9701b119482ee9ddac3
Merge pull request #2735 from jkozera/bugfix-1151436

Fix bug 1151436. Handle signatures over 255 chars correctly.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.