Last Comment Bug 1151440 - Choose a color not responsive when creating a New calendar in Lightning 4.0b1
: Choose a color not responsive when creating a New calendar in Lightning 4.0b1
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: General (show other bugs)
: Lightning 4.0.0.1
: x86_64 Linux
-- normal (vote)
: 4.0.0.1
Assigned To: Matthew Mecca [:mmecca]
:
:
Mentors:
: 1153689 1165278 (view as bug list)
Depends on: 1139315
Blocks: ltn40
  Show dependency treegraph
 
Reported: 2015-04-06 06:58 PDT by WaltS48
Modified: 2015-05-19 10:11 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Modal dialog workaround (3.13 KB, patch)
2015-04-23 15:15 PDT, Matthew Mecca [:mmecca]
philipp: feedback+
richard.marti: feedback+
Details | Diff | Splinter Review
Workaround v2 - linux only (5.62 KB, patch)
2015-04-25 17:05 PDT, Matthew Mecca [:mmecca]
philipp: review+
richard.marti: feedback+
philipp: approval‑calendar‑aurora+
philipp: approval‑calendar‑beta+
Details | Diff | Splinter Review

Description User image WaltS48 2015-04-06 06:58:52 PDT
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150330154247

Steps to reproduce:

Select Calendar tab
Right-click on Home
Select "New Calendar..."
Select "On My Computer" from the Create New Calendar window
Click "Next"
Enter a name in the "Name:" field
Click the Color button



Actual results:

Choose a color dialog box opens
Choose a color pop-up dialog not responding to any input.
Click the "x" on the Create New Calendar window to cancel creation of a new calendar


Expected results:

Should have been able to select the color in any way possible.
Comment 1 User image [:MakeMyDay] 2015-04-06 10:09:54 PDT
Is there any message in the error console (ctrl+shift+j)?
Comment 2 User image WaltS48 2015-04-06 15:10:44 PDT
(In reply to MakeMyDay from comment #1)
> Is there any message in the error console (ctrl+shift+j)?

All I see on Start-up of Thunderbird 38.0b1 is;

Timestamp: 04/06/2015 06:03:38 PM
Warning: Use of Mutation Events is deprecated. Use MutationObserver instead.
Source File: chrome://calendar/content/widgets/calendar-widgets.xml
Line: 496

Nothing appears in the Error Console, after I clear the Error Console, and then try to create a new calendar.
Comment 3 User image [:MakeMyDay] 2015-04-12 02:28:47 PDT
We use the color picker from the OS/Desktop environment. On what distribution / desktop environment are you (I gues you're on Linux 64 bit based on your browser signature in you report)?
Comment 4 User image WaltS48 2015-04-12 06:34:05 PDT
Why is the color picker a drop down with a bunch of colored squares with Lightning 3.3.3, and a separate Choose a Color window, with a color circle, eyedropper under that, a Hue, Saturation and Value column with a Color Name field under that and a Red, Green and Blue column if you use the color picker from the OS/Desktop environment?

Choosing a color works in Lightning 3.3.3.

Anyway I am using Kubuntu 14.10 and the KDE 4.14.1 desktop environment.
Comment 5 User image [:MakeMyDay] 2015-04-12 07:27:23 PDT
Thank you for the swift reply. This has been changed with bug 1002597.

Philipp, will you have a look at this?
Comment 6 User image WaltS48 2015-04-12 08:36:37 PDT
Your welcome.

Doesn't work with Categories either. I have to Quit Thunderbird to dismiss the Choose a Color dialog window.
Comment 7 User image Richard Marti (:Paenglab) 2015-04-12 10:11:37 PDT
I can confirm under Linux Mint. Opening the system color chooser blocks TB and the chooser. I have to kill TB.
Comment 8 User image Philipp Kewisch [:Fallen] 2015-04-12 11:48:20 PDT
My Linux machine isn't easy to boot thanks to a bluetooth keyboard and no grub support for a bluetooth stack. I'll see if I can get to this some time this week. If someone else wants to take over please do.
Comment 9 User image [:MakeMyDay] 2015-04-12 23:36:32 PDT
*** Bug 1153689 has been marked as a duplicate of this bug. ***
Comment 10 User image Stefan Sitter 2015-04-14 12:57:34 PDT
Could you test if the HTML5 color picker works in Firefox 38 on Linux, e.g. be testing the demo on <http://www.wufoo.com/html5/types/6-color.html>? This information might be useful to decide if this is problem in Core/Toolkit or Thunderbird/Lightning.
Comment 11 User image WaltS48 2015-04-14 18:06:47 PDT
(In reply to Stefan Sitter from comment #10)
> Could you test if the HTML5 color picker works in Firefox 38 on Linux, e.g.
> be testing the demo on <http://www.wufoo.com/html5/types/6-color.html>? This
> information might be useful to decide if this is problem in Core/Toolkit or
> Thunderbird/Lightning.

Everything on the demo works for me using 64-bit Firefox 38.0b4 on Linux.
Comment 12 User image Stefan Sitter 2015-04-21 13:14:15 PDT
So what should we do? Back-out the html color picker patch and revert to the old but working xul color picker? Or accept the fact that the color selection feature is broken for users running Linux?
Comment 13 User image [:MakeMyDay] 2015-04-21 14:37:55 PDT
If this cannot be fixed in time, we should consider to back this out from beta. Based on the reports, it's not just broken but requires TB to be killed.
Comment 14 User image WaltS48 2015-04-21 17:58:07 PDT
Thunderbird only needs to be killed if you are creating a new Category. Wouldn't fixing it for creating a New Calendar fix both problems?

If not I'm for reverting to the old but working xul color picker.
Comment 15 User image Matthew Mecca [:mmecca] 2015-04-23 15:15:27 PDT
Created attachment 8596864 [details] [diff] [review]
Modal dialog workaround

This seems to be triggered by opening the color picker from a modal dialog. Opening the dialogs as modeless would be one workaround.
Comment 16 User image Philipp Kewisch [:Fallen] 2015-04-23 23:57:15 PDT
I suspsected this might be a workaround. We should file a core bug for this, although I doubt it will be fixed in the 4.0 timeframe. If this happens only on Linux, I think we should use this workaround only for Linux. Making these dialogs non-modal can be quite messy when switching windows.
Comment 17 User image Philipp Kewisch [:Fallen] 2015-04-24 00:06:02 PDT
Comment on attachment 8596864 [details] [diff] [review]
Modal dialog workaround

r+ if made Linux-only with a comment to this bug. I'd like to get some feedback from Paenglab on the UX here too.
Comment 18 User image Stefan Sitter 2015-04-24 01:36:33 PDT
Looks like the problem with Lightning was already observed some time ago and filed as Core Bug 1139315 but no information was send to the Lightning community.
Comment 19 User image Richard Marti (:Paenglab) 2015-04-24 02:23:26 PDT
Comment on attachment 8596864 [details] [diff] [review]
Modal dialog workaround

f+ also for Linux only. I tested it on Linux and Windows. On Windows the dialog could jump behind TB and then everything works but a new try to open the properties fails for the user (not really, but the dialog doesn't jump in front). On Linux interestingly the dialog and the color picker are staying always in front of TB.
Comment 20 User image Matthew Mecca [:mmecca] 2015-04-25 17:05:21 PDT
Created attachment 8597661 [details] [diff] [review]
Workaround v2 - linux only

Opens dialogs as modeless in linux only.

Could someone also confirm this works as expected on mac / windows?
Comment 21 User image Richard Marti (:Paenglab) 2015-04-26 01:59:25 PDT
Comment on attachment 8597661 [details] [diff] [review]
Workaround v2 - linux only

Not really a ui-r, so f+

Tested on Win7 and Linux Mint.
Comment 23 User image Stefan Sitter 2015-05-04 04:40:44 PDT
Philipp, could you include this in the next 4.0 Beta build?
Comment 24 User image Philipp Kewisch [:Fallen] 2015-05-04 15:22:47 PDT
Backported to releases/comm-aurora changeset 7fc89b45e3fc
Comment 25 User image Philipp Kewisch [:Fallen] 2015-05-04 15:23:30 PDT
Backported to releases/comm-beta changeset e6bca55b38c9
Comment 26 User image Philipp Kewisch [:Fallen] 2015-05-04 15:24:13 PDT
Sure, sorry this went by unnoticed.
Comment 27 User image Stefan Sitter 2015-05-15 04:16:08 PDT
*** Bug 1165278 has been marked as a duplicate of this bug. ***
Comment 28 User image Stefan Sitter 2015-05-19 09:35:48 PDT
If you want to test (and hopefully verify) the fix before Lightning 4.0b5 is officially available on addons.mozilla.org please try a test build from https://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/candidates/4.0b5-candidates/build1/
Comment 29 User image WaltS48 2015-05-19 10:11:16 PDT
I've been using it, and can verify the fix works for me when creating a new calendar or category.

Note You need to log in before you can comment on or make changes to this bug.