Quick Filter by "Sender" doesn't use name from address book

RESOLVED DUPLICATE of bug 460737

Status

Thunderbird
Search
RESOLVED DUPLICATE of bug 460737
3 years ago
3 years ago

People

(Reporter: Will T., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Let's say you have "Aunt Dorris" listed in your address book with her e-mail address, "fmd1965@example.com". Let's also assume that her e-mail client only sends her e-mail address in the "From:" line (as opposed to also including her name) ...

Now if you use Quick Filter by "Sender" and type in "Aunt Dorris", you won't get any results, because it's only looking at the "From:" line of the message, and not at the associated entry in the address book :-/

This is exceptionally confusing since the "From" column in the message list shows her name from the address book.

Please fix :-)

Comment 1

3 years ago
xref bug 151789
Thanks Will for reporting and yes, that's very annoying. I reported this before as 460737. It's also not as trivial to fix as it may look, but it must be fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 460737
You need to log in before you can comment on or make changes to this bug.