Hosting for viewsourceconf.org

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: SSL and Domain Names
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: ali spivak, Assigned: fox2mike)

Tracking

Details

(Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/894] )

(Reporter)

Description

3 years ago
Looking to move a domain (viewsourceconf.org) and setup website hosting for a new website for upcoming Mozilla View Source conference. 

Have purchased the domain name but need to host it plus the code. We will be collecting user data from the site so it needs to be under Mozilla infrastructure. Site will be developed by an outside vendor

Updated

3 years ago
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/894]
(Reporter)

Comment 1

3 years ago
Is there a better forum/place for me to place this request?
(Assignee)

Comment 2

3 years ago
Ali, 

Let's touch base here before we decide how to get this going. Would you like me to schedule something on Vidyo? or are you in SF this week? 

Thanks!
Assignee: server-ops-webops → smani
(Reporter)

Comment 3

3 years ago
Hi Shyam, let's meet on Vidyo? I'm WFH today (friday), in the SF office Monday & Tuesday, and then on PTO afterwards
(Assignee)

Comment 4

3 years ago
(In reply to ali spivak from comment #3)
> Hi Shyam, let's meet on Vidyo? I'm WFH today (friday), in the SF office
> Monday & Tuesday, and then on PTO afterwards

I was in your Vidyoroom today for 10 mins based on the invite I had, seems like you aren't around :) 

Happy to catch up, just drop me another invite. Thanks!
(Assignee)

Comment 5

3 years ago
Met with Ali today, the site is going to be a static site for the most part (from what we know for now) with about 10-15 pages. This is for a conference we're planning to host in November.  

My initial idea here is to just host off S3/EC2 (and not add anything to the datacenters). Also spinning off a bug to transfer the domain once the transfer lock (60 days) has expired. 

Ali will also invite us over to the next meeting with the vendor so we have some idea on what sort of site to expect by November.
Summary: Website hosting request → Hosting for viewsourceconf.org
(Reporter)

Updated

3 years ago
Blocks: 1140545
(Assignee)

Comment 6

3 years ago
Have an email thread with Ali about the github repos for this etc. I believe we're looking to move the (current, developer side) github repo into our mozilla team account before we set this up.
(Assignee)

Updated

3 years ago
Summary: Hosting for viewsourceconf.org → Hosting for viewsourceconf.com
(Assignee)

Comment 7

3 years ago
And we have that repo - https://github.com/mdn/viewsourceconf 

Looks like we'll set this up on the static cluster afterall.
Depends on: 1164280
How's this coming along?
Flags: needinfo?(smani)
Depends on: 1170248
Depends on: 1170250
(Assignee)

Comment 9

3 years ago
https://viewsourceconf.com/ is now live and automatically updates from the github repo in comment #7 twice an hour.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(smani)
Resolution: --- → FIXED
I've confirmed this is live. Thank you!

I have a few changes:

* primary domain needs to be viewsourceconf.org with a redirect to viewsourceconf.com
* please pull from production branch of git repo: https://github.com/mdn/viewsourceconf/tree/production
* could you put a simple .htaccess password on the site? we're not quite ready for it to be 'live' to the public

Let me know if I should file separate bugs for these items. Thanks!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

3 years ago
Depends on: 1172096
(Assignee)

Comment 11

3 years ago
(In reply to Christie Koehler [:ckoehler] from comment #10)
> I've confirmed this is live. Thank you!
> 
> I have a few changes:
> 
> * primary domain needs to be viewsourceconf.org with a redirect to
> viewsourceconf.com

This needs Bug 1172096 to be fixed and we can take next steps. 

> * please pull from production branch of git repo:
> https://github.com/mdn/viewsourceconf/tree/production

Fixed on prod, it'll get pushed out soon.

> * could you put a simple .htaccess password on the site? we're not quite
> ready for it to be 'live' to the public

This is also in place and will be active once puppet runs complete. Password passed on to Christie for now and added to Webops GPG.
(Assignee)

Updated

3 years ago
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Summary: Hosting for viewsourceconf.com → Hosting for viewsourceconf.org
We're almost ready to go live with this. 

One thing I noticed, though, is that viewsourceconf.org is redirecting to viewsourceconf.com and it needs to be the other way around. ssl certs look good.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Looks like the redirect is working as expected now. 

We're ready to remove the .htaccess password. Thanks!
Friendly ping to say we're ready to go live with this (remove .htaccess) password.
Flags: needinfo?(smani)
I have just removed the .htaccess password. Please give it 20 minutes (or so) to replicate.
Flags: needinfo?(smani)
Hello all! Are we happy/done here?
(Reporter)

Comment 17

3 years ago
Yes, I think this is taken care of
(Assignee)

Updated

3 years ago
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.