Incorrect instance when using multiple profiles.

RESOLVED DUPLICATE of bug 441422

Status

()

Toolkit
Startup and Profile System
RESOLVED DUPLICATE of bug 441422
3 years ago
3 years ago

People

(Reporter: Brian Vanderburg, Unassigned)

Tracking

36 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

# Basically, assume that two different instances of Firefox are already open, using two different profiles:
firefox -P default -new-instance 
firefox -P empty -new-instance

# Later, it may be desired to act with a specific instance, or a the default instance.  The "default" instance would be the first instance launched,
firefox --new-tab http://www.google.com

# While a specific instance can be specified by specifying the profile, either -P <name> or -profile <path>
firefox -P empty http://www.google.com


Actual results:

Two tabs opened in the instance associated with the default profile.


Expected results:

One tab should have opened in each of the instances.

To elaborate, apparently only the first instance of the application gets control of the "remote".  It seems that it could be desirable for each instance of the application to have its own remote, with the first instance being the default used if none is specified by later commands, thus allowing a command to open one tab in one existing instance, and another tab in another existing instance.

Furthermore, it could be useful to have a way to specify a command but select the remote from the drop-down lists.  Something like this could be put in a .desktop file:

    Exec=firefox -profile-manager --new-tab %U

This could result in the profile-manager showing all known profiles, and allowing the user to select a profile.  If an instance is already open, then that instance would be used.  When viewing email or other documents, after clicking on a link, I could choose to open it in any existing Firefox instance (I normally have two at least, one default and one mostly empty)

The above could probably apply to other applications such as Thunderbird as well.

Comment 1

3 years ago
Bug 441035, comment 3
Bug 441422, comment 12
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Untriaged → Startup and Profile System
Product: Firefox → Toolkit
Resolution: --- → DUPLICATE
Duplicate of bug: 441422
You need to log in before you can comment on or make changes to this bug.