If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

There's an upper bound on the size of text that can be rendered with CanvasRenderingContext2D.fillText()

RESOLVED DUPLICATE of bug 729672

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 729672
3 years ago
3 years ago

People

(Reporter: colons, Unassigned)

Tracking

36 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150320202338

Steps to reproduce:

- visit https://colons.co/tether/
- score at least one point before dying
- die


Actual results:

- the score in the background sits static at what is presumably firefox's maximum canvas text size for a few seconds before beginning to shrink


Expected results:

- the score should start much larger than the screen and slowly trend towards zero (both blink and webkit get this right)
(Reporter)

Comment 1

3 years ago
it's not necessarily completely necessary to score a point, but it's way easier to see the issue when the number is 2 instead of 1. alternatively, you could set game.score to something higher than 0 in the console while on the title screen.
(Reporter)

Updated

3 years ago
Summary: There's an upper bound on the size of font that can be rendered with the CanvasRenderingContext2D.fillText() → There's an upper bound on the size of font that can be rendered with CanvasRenderingContext2D.fillText()
(Reporter)

Updated

3 years ago
Summary: There's an upper bound on the size of font that can be rendered with CanvasRenderingContext2D.fillText() → There's an upper bound on the size of text that can be rendered with CanvasRenderingContext2D.fillText()

Comment 2

3 years ago
Dupe Bug 729672 ?
(Reporter)

Comment 3

3 years ago
Yep. Didn't show up in my searches, sorry.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 729672
You need to log in before you can comment on or make changes to this bug.