[Contacts] If the Delete Contacts UI is accessed just before the app is closed, the Contact Selection UI will briefly appear on screen the next time the app is launched.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Marty, Assigned: ferjm)

Tracking

({regression})

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8588738 [details]
logcat-contacts-launch-cache.txt

Description:
If the Delete Contacts UI is accessed from settings just before the app is closed by the user, the next time the Contacts app is launched, the user will briefly see the Selection UI check boxes overlapping each of the contact names.

Repro Steps:
1) Update a Flame to 20150406010204
2) Launch the Contacts app and create 1 or more contacts.
3) Tap the Gear Icon to open settings and select 'Delete Contacts'
4) Tap the 'X' to dismiss the delete selection UI, then close the Contacts app
5) Relaunch the Contacts app

Actual:
Selection UI Check Boxes briefly overlap each contact name after launch.

Expected:
Selection UI is not shown on app start-up.

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150406010204
Gaia: ef61ebbe5de8c2c9fc2a8f74a12455044c3b82e9
Gecko: 4fe763cbe196
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 8/8
See attached: Logcat, Video (URL)
(Reporter)

Comment 1

3 years ago
This issue DOES occur on Flame 2.2 builds.
Selection UI Check Boxes briefly overlap each contact name after launch.

Environmental Variables:
Device: Flame 2.2 (319MB)(Full Flash)
Build ID: 20150406002503
Gaia: a6351e1197d54f8624523c2db9ba1418f2aa046f
Gecko: c3335a5d3063
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Doesn't repro on 2.1[1]. It seems like a fallout of bug 1112551. It looks like /contacts/js/views/list.js is loaded a bit too late to remove the .contact-checkbox class before the user sees it. Is it something we can easily fix, Fernando?

[1] Build ID               20150406161207
Gaia Revision          87e55a7ec688138812181747f690fd188d2a0668
Gaia Date              2015-04-03 21:43:01
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/747b6132c44d
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20141120.194707
Firmware Date          Thu Nov 20 19:47:17 EST 2014
Bootloader             L1TC00011880
Blocks: 1112551
status-b2g-v2.1: --- → unaffected
Flags: needinfo?(ferjmoreno)
Keywords: regression
(Assignee)

Updated

3 years ago
Assignee: nobody → ferjmoreno
Flags: needinfo?(ferjmoreno)
[Blocking Requested - why for this release]:
UX regression, starting with a 3.0 nomination as it's non-functional and recovers quickly.

Requesting a window to confirm Comment 2 that it's a regression from bug 1112551.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
I'm not sure the regression window is needed. It'll probably point to bug 1112551 or one of its follow up. Fernando, if you think I'm mistaken, please put the keyword back.

Moving the nom to 2.2 as this regression happened in this version.
blocking-b2g: 3.0? → 2.2?
Keywords: regressionwindow-wanted
(Assignee)

Comment 5

3 years ago
I am not sure if this is caused by bug 1112551. The cache is already built when we enter in the select contacts screen, so the checkboxes are not part of the cache. I still need to look into it, but a regression window would be appreciated.
Keywords: regressionwindow-wanted
(Assignee)

Comment 6

3 years ago
Actually, it might be caused by bug 1112551. This is happening if we enter the select contact screen before the cache is built (we defer it 1 second, so it is possible that this happens)
Keywords: regressionwindow-wanted
Created attachment 8589214 [details] [review]
[gaia] ferjm:bug1151594.contacts.delete.checkbox > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8589214 - Flags: review?(francisco)
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1148654

Updated

3 years ago
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8589214 [details] [review]
[gaia] ferjm:bug1151594.contacts.delete.checkbox > mozilla-b2g:master

Love this one liners :)
Attachment #8589214 - Flags: review?(francisco) → review+
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/29379

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
Landed:

https://github.com/mozilla-b2g/gaia/commit/89ce9aa7ecf15050ee15fab905a942d6276879e4
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Comment on attachment 8589214 [details] [review]
[gaia] ferjm:bug1151594.contacts.delete.checkbox > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Regression due to performance improvements
[User impact] if declined:
Bad user experience
[Testing completed]:
Tested on master
[Risk to taking this patch] (and alternatives if risky):
Pretty low
[String changes made]:
Attachment #8589214 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8589214 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/6208a01c6361adc0fe333226cedac88a1d3be66b
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
Target Milestone: --- → 2.2 S10 (17apr)
Verified that this issue is fixed on Flame 3.0 and 2.2. Following STR, Contacts app is not launched briefly displaying contact selection UI.

Bug 1148654 that was duped to this bug is not completely fixed. Un-duping and updating bug 1148654.

Device: Flame 3.0
BuildID: 20150414072436
Gaia: c8cb0c0ebb8dd1f5c0c9037e38f8e4b237beb77b
Gecko: 388f5861dc7d
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Device: Flame 2.2
BuildID: 20150414002504
Gaia: 73645b097720f3ca594a14d288b87d3885d7fc9d
Gecko: 85ea1be9ac7d
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.