mobile network not detected when there is only a case difference

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Settings
RESOLVED WONTFIX
3 years ago
4 months ago

People

(Reporter: Praveen A, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8588918 [details]
HTC network list

User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Build ID: 20141008000202

Steps to reproduce:

I have an airtel sim card with zte open c. I have 3g active on this Sim (works on HTC dream/t mobile g1). 


Actual results:

I cannot get 3g. Because there are two networks visible in HTC dream which differ in case only. Airtel and airtel. First one is 2g only and second one 3g network. I can verify it by connecting to each network from my HTC phone. But Firefox OS 2.0 pre release and 1.3 shows only one network in the list and connects only to the 2g network.


Expected results:

I should get 3g. I think zte open c us model is compatible in India. Attaching screenshots of both HTC and zte network list.
(Reporter)

Comment 1

3 years ago
Created attachment 8588919 [details]
zte network list

Zte open c shows only 'airtel' in the list and does no show 'Airtel' like HTC dream.
(Reporter)

Comment 2

3 years ago
Created attachment 8588923 [details]
zte connected network

Even though it shows 'airtel' in the list, it is connecting to 'Airtel' since it can't differenciate they are two different networks and I can't get 3g.

Comment 3

4 months ago
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.