Read messages link in account central page downloads messages

VERIFIED WONTFIX

Status

MailNews Core
Networking: POP
--
major
VERIFIED WONTFIX
16 years ago
9 years ago

People

(Reporter: Sheela Ravindran, Assigned: racham)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Buildid: 2001-12-13-06

Read messages link on the account central page starts downloading messages.
Steps: 
Create a new pop account
Enter the password at the password dialog
You will see the green arrow at the account level
Click on the account name
Then click on the Read Messages link 

Actual: The messages are downloaded from the server.

I thought only get message button would start downloading messages. But we also
download messages by clicking on Read Messages.  But this will be a problem when
the user did not expect this and wanted to leave messages on the server.  Now
the messages are gone from the server.  
I don't think we should start downloading message when we click on the Read
Messages..  Else for pop accounts it should say Get Messages instead of Read
Messages.
Jennifer is this behavior okay? Because there has been some requests to not Get
Messages in any way other than clicking on Get message button because user might
want to leave messages on the server.

Comment 1

16 years ago
Jennifer, what's your opinion on this?  I assumed that Read Messages would
download your messages for you.

reassigning to racham.
Assignee: naving → racham

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 2

16 years ago
That was my thought too, that "Read Messages" would get new messages and display 
the Inbox. I understand the potential confusion with POP accts, but I would  
recommend leaving the behavior as it is for now, and see what sort of feedback 
we get. 

Comment 3

16 years ago
Changing to WONTFIX then.  If we change our minds, we can reopen.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

16 years ago
Verifying as won't fix. I guess for now it is wontfix. I will reopen the bug if 
I see more bugs reported against this behavior.  
Status: RESOLVED → VERIFIED

Comment 5

16 years ago
*** Bug 126001 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.