[Flame][Download]There is a scroll bar on Select download page even there no downloads.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
a year ago

People

(Reporter: xiongfuchao, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(2 attachments)

Created attachment 8589017 [details]
video_0250.mp4

[1.Description]:
[Flame][v2.2 & v3.0][Email]When user opens Select download page from Email they will find there is a scroll bar and they can scroll the page even there no downloaded file.
Found time:02:50
Sttachment:logcat_0250.txt & video_0250.mp4
[2.Testing Steps]: 
Prerequisite:No any downloads,set a email accont sign in.
1.Open Email.
2.Tap compose icon to create an email.
3.Tap on Paper Clip icon.
4.Select Downloads.

[3.Expected Result]: 
4.No scroll bar is in this page.

[4.Actual Result]: 
4.There is a scroll bar in this page and user can scroll it.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150406002503
Gaia Revision          a6351e1197d54f8624523c2db9ba1418f2aa046f
Gaia Date              2015-04-03 22:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c3335a5d3063
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.040047
Firmware Date          Mon Apr  6 04:00:58 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 version(Affected):
Build ID               20150406160205
Gaia Revision          834385f4c834238a4306bf87cc4be41615d91ff0
Gaia Date              2015-04-06 19:41:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a530b5c3b713
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.194015
Firmware Date          Mon Apr  6 19:40:27 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
No scroll bar when there has any downloads and height not over the page.
(Reporter)

Comment 1

4 years ago
Created attachment 8589019 [details]
logcat_0250.txt
(Reporter)

Updated

4 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
This is not the email app.  This is the "download" app that provides the pick activity.  Since it lacks its own bugzilla component but is the other half of the "downloads" logic provided by the settings app, I'm putting this in the settings bugzilla component.  cc'ing :crdlc who added the download app in bug 848400 and :francisco who r+'d it since they might have a better idea of the correct component/etc. for this.
Component: Gaia::E-Mail → Gaia::Settings
Summary: [Flame][Email]There is a scroll bar on Select download page even there no downloads. → [Flame][Download]There is a scroll bar on Select download page even there no downloads.
(Reporter)

Comment 3

4 years ago
The bug can be reproduced on latest build of Flame v2.2 v3.0, Nexus5 v2.2 v3.0 by the STR in comment 0.
Actually Result:There is a scroll bar in this page and user can scroll it.
Reproduce rate:5/5
See attachment:video_0250.mp4

Device:Flame v2.2 build(Affected)
Build ID               20150528002504
Gaia Revision          999bc627063d16c20f703e702f31a5cf0da8b4a6
Gaia Date              2015-05-28 02:16:40
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/351101ec82ba
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150528.034806
Firmware Date          Thu May 28 03:48:15 EDT 2015
Bootloader             L1TC000118D0

Device:Flame v3.0 build(Affected)
Build ID               20150528160205
Gaia Revision          e7d268074ee3c9eeb191c2205c0e35992fb3915d
Gaia Date              2015-05-28 10:47:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f986e55c4e0b
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150528.192335
Firmware Date          Thu May 28 19:23:44 EDT 2015
Bootloader             L1TC000118D0

Device:Nexus 5 v2.2 build(Affected)
Build ID               20150528002504
Gaia Revision          999bc627063d16c20f703e702f31a5cf0da8b4a6
Gaia Date              2015-05-28 02:16:40
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/351101ec82ba
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150528.040306
Firmware Date          Thu May 28 04:03:25 EDT 2015
Bootloader             HHZ12f

Device:Nexus 5 v3.0 build(Affected)
Build ID               20150528160205
Gaia Revision          e7d268074ee3c9eeb191c2205c0e35992fb3915d
Gaia Date              2015-05-28 10:47:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f986e55c4e0b
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150528.191717
Firmware Date          Thu May 28 19:17:35 EDT 2015
Bootloader             HHZ12f
(Reporter)

Updated

4 years ago
QA Whiteboard: [MGSEI-Triage+]

Comment 4

a year ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.