www.legato.com crashes under Solaris

CLOSED DUPLICATE of bug 57223

Status

()

Core
Plug-ins
CLOSED DUPLICATE of bug 57223
17 years ago
17 years ago

People

(Reporter: Ping Liao, Assigned: Sergi)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Mozilla NETSCAPE__6_2_1_RELEASE crashes when trying to access www.legato.com
when 24 bits per pixel is used, it works if 8 bpp is used (albeit looking
rough).  It seems just the reverse of bug 85958.

The Workshop debug stack:
   main(argc = 1, argv = 0xffbeefa4)
   main1(argc = 1, argv = 0xffbeefa4, nativeApp = (nil))
   nsAppShellService::Run(this = 0x171ca8)
   nsAppShell::Run(this = 0x1607b8)
   gtk_main()
   g_main_run(loop = 0x197fe8)
   g_main_iterate(block = 1, dispatch = 1)
   g_main_dispatch(current_time = 0xffbee8d0)
   g_idle_dispatch(source_data = 0xfd7f0cc0, current_time = 0xffbee8d0,user_data
=(nil))
   nsWindow::UpdateIdle(data = (nil))
   nsWindow::Update(this = 0x91a448)
   nsWindow::DoPaint(this = 0x91a448, aX = 0, aY = 0, aWidth = 974, aHeight =
703,aClipRegion = 0x916dd8)
   nsWidget::DispatchWindowEvent(this = 0x91a448, event = 0xffbee574)
   nsWidget::DispatchEvent(this = 0x91a448, aEvent = 0xffbee574, aStatus =
 nsEventStatus_eIgnore)
   HandleEvent(aEvent = 0xffbee574)
   nsViewManager::DispatchEvent(this = 0x7e85d0, aEvent = 0xffbee574, aStatus =
 0xffbee3a8)
   nsViewManager::Refresh(this = 0x7e85d0, aView = 0x91a3c0, aContext =
0x936408, rect = 0xffbee310, aUpdateFlags = 1U)
   nsViewManager::RenderViews(this = 0x7e85d0, aRootView = 0x91a3c0, aRC =CLASS,
 aRect = STRUCT, aResult = 0)
   nsViewManager::RenderDisplayListElement(this = 0x7e85d0, element = 0x9367c0,
aRC = CLASS)
   nsBlender::Blend(this = 0x830910, aSX = 0, aSY = 0, aWidth = 156, aHeight =
266, aSrc = 0x98bab8, aDest = 0x98ba18, aDX = 0, aDY = 0, aSrcOpacity = 0.9,
aSecondSrc =
 0x98bb58, aSrcBackColor = 4278190080U, aSecondSrcBackColor = 4294967295U)
   nsBlender::Blend(this = 0x830910, aSX = 0, aSY = 0, aWidth = 156, aHeight =
266, aSrc = 0x98b8a8, aDst = 0x98b7f0, aDX = 0, aDY = 0, aSrcOpacity = 0.9,
aSecondSrc =
 0x98b960, aSrcBackColor = 4278190080U, aSecondSrcBackColor = 4294967295U)
   nsBlender::Blend(this = 0x830910, aSrcBits = 0xa1fd98 "", aSrcStride = 624,
 aDestBits = 0xa48600 "", aDestStride = 624, aSecondSrcBits = 0xa70e68 "",
aSrcBytes = 624, aLines = 266, aOpacity = 0.9)
  nsBlender::Do24Blend(this = 0x830910, aOpacity = 0.9, aNumLines =
266,aNumBytes = 624, aSImage = 0xa1fd98 "", aDImage = 0xa48600 "", aSecondSImage
= 0xa70e68 "",aSLSpan = 624, aDLSpan = 624, aBlendQuality = nsHighQual)

At end, a bus error was encountered:
 signal BUS (invalid address alignment) in nsBlender::Do24Blend at line 475 in
file "nsBlender.cpp"


Reproducible: Always

Steps to reproduce: 
on Netscape 6.x Solaris sparc, access  http://www.legato.com
(display on Solaris box with default color depth of 24 bpp)

Actual result: crash (Bus error)

Expected result: access the same page on NS 4.7x or NS 6.x on Linux/Windows
(Assignee)

Comment 1

17 years ago
Reporter: can you give output of 'xdpyinfo' on your station?
I'm interesting in default visual and list of allowed visuals.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 2

17 years ago
Here is the xdpyinfo output:

sandhill<tcsh 223> xdpyinfo
name of display:    :0.0
version number:    11.0
vendor string:    Sun Microsystems, Inc.
vendor release number:    6410
maximum request size:  262140 bytes
motion buffer size:  256
bitmap unit, bit order, padding:    32, MSBFirst, 32
image byte order:    MSBFirst
number of supported pixmap formats:    3
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
    depth 24, bits_per_pixel 32, scanline_pad 32
keycode range:    minimum 8, maximum 132
focus:  window 0x600003f, revert to Parent
number of extensions:    28
    AccessX
    Adobe-DPS-Extension
    DOUBLE-BUFFER
    DPMS
    DPSExtension
    Extended-Visual-Information
    FBPM
    LBX
    MIT-SCREEN-SAVER
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    Multi-Buffering
    RECORD
    SECURITY
    SHAPE
    SUN_ALLPLANES
    SUN_DGA
    SUN_OVL
    SUN_SME
    SYNC
    SolarisIA
    TOG-CUP
    XC-APPGROUP
    XC-MISC
    XIE
    XInputDeviceEvents
    XInputExtension
    XTEST
default screen number:    0
number of screens:    1

screen #0:
  dimensions:    1280x1024 pixels (361x288 millimeters)
  resolution:    90x90 dots per inch
  depths (3):    1, 8, 24
  root window id:    0x37
  depth of root window:    24 planes
  number of colormaps:    minimum 1, maximum 5
  default colormap:    0x34
  default number of colormap cells:    256
  preallocated pixels:    black 0, white 16777215
  options:    backing-store YES, save-unders YES
  largest cursor:    64x64
  current input event mask:    0x78003f
    KeyPressMask             KeyReleaseMask           ButtonPressMask          
    ButtonReleaseMask        EnterWindowMask          LeaveWindowMask          
    SubstructureNotifyMask   SubstructureRedirectMask FocusChangeMask          
    PropertyChangeMask       
  number of visuals:    16
  default visual id:  0x28
  visual:
    visual id:    0x27
    class:    StaticGray
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x20
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x21
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x22
    class:    StaticColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x23
    class:    StaticGray
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x24
    class:    GrayScale
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x25
    class:    TrueColor
    depth:    8 planes
    available colormap entries:    8 per subfield
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x26
    class:    DirectColor
    depth:    8 planes
    available colormap entries:    8 per subfield
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x2e
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x2f
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    255
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x2c
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x2d
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x28
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x29
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x2a
    class:    DirectColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x2b
    class:    DirectColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits
(Assignee)

Comment 3

17 years ago
Reporter, can you reproduce but with more recent build?
I cannot reproduce bug with trunk and 0.9.6. Probably this
bug is duplicate of 57223, and already fixed.
I think so becase bus error is exactly alignment problem for sparc/solaris.

*** This bug has been marked as a duplicate of 57223 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

17 years ago
Close bug as dup of already fixed 57223.
Status: RESOLVED → CLOSED
You need to log in before you can comment on or make changes to this bug.