Closed Bug 1151795 Opened 6 years ago Closed 4 years ago

The Reading List remove button from Reader View's footer is not adapting to high-contrast themes

Categories

(Toolkit :: Reader Mode, defect, P4)

38 Branch
x86_64
Windows 7
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox38 --- affected
firefox39 --- affected
firefox40 --- affected

People

(Reporter: avaida, Unassigned)

References

Details

Attachments

(1 file)

Reproducible on:
Nightly 40.0a1 (2015-04-06), Aurora 39.0a2 (2015-04-06), Beta 38.0b2-build1 (20150406174117)

Affected platforms:
Windows 7 (x64), Windows 8.1 (x64)

Preconditions:
* the user has a high-contrast theme set

Steps to reproduce:
1. Launch Firefox.
2. Open a Reader View compatible page - (e.g) http://www.bbc.com/news/magazine-32160231
3. Click the "Enter Reader View" button from the Location Bar.
4. Click the "Add page to Reading List" button from the Location Bar.
5. Check Reader View's footer.

Expected result:
The footer as well as the button it contains are properly adapting to high-contrast themes.

Actual result:
The button's hover styling is not adapting to high-contrast themes.
So, it seems to me that none of the in-page content (reading mode footer and reading mode toolbar) nor the sidebar is reacting to the high-contrast theme.  Now, the base page also doesn't react to high-contrast themes, so I'm not sure whether the in-page content should, but I suspect the sidebar at least should (since the bookmarks sidebar does).

Does that sound reasonable, Philipp?
Flags: needinfo?(philipp)
(In reply to Blake Winton (:bwinton) from comment #1)
> So, it seems to me that none of the in-page content (reading mode footer and
> reading mode toolbar) nor the sidebar is reacting to the high-contrast
> theme.  Now, the base page also doesn't react to high-contrast themes, so
> I'm not sure whether the in-page content should, but I suspect the sidebar
> at least should (since the bookmarks sidebar does).
> 
> Does that sound reasonable, Philipp?

That does sound reasonable.

From the screenshot it seems like the delete button is actually regressing in high contrast mode (white text), so that should be fixed.
Flags: needinfo?(philipp)
I could not replicate that with my current set of patches, so hopefully that'll be fixed by bug 1149649.
Priority: -- → P4
We no longer have a delete button.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.