[RTL] Ellipsis is at the left of an LTR phone label on the contact edit page

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Contacts
P3
normal
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: jlorenzo, Unassigned)

Tracking

(Blocks: 2 bugs)

unspecified
x86_64
Linux
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.5-rtl-test-run])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
As discovered in bug 1134961 comment 44, the ellipsis is at the left of an LTR phone label when you're in Arabic. See the attached screenshot.

Repro'd on master[1] and 2.2[2].

[1] Build ID               20150407010204
Gaia Revision          c710bac533b76635161315bf907d004e000549cb
Gaia Date              2015-04-06 23:49:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ab0490972e1e
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.044416
Firmware Date          Tue Apr  7 04:44:28 EDT 2015
Bootloader             L1TC000118D0

[2] Build ID               20150407002501
Gaia Revision          5e09637414269728f6f1bc0152d0160f3b6b380e
Gaia Date              2015-04-07 05:16:37
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/245f37f44017
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.040845
Firmware Date          Tue Apr  7 04:08:57 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Comment 1

3 years ago
Created attachment 8589127 [details]
Screenshot - Arabic - Master
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
RTL triage: P3 for the edgiest of use cases :)
Priority: -- → P3

Comment 3

3 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15385/
Flags: in-moztrap+

Comment 4

3 years ago
Hi William,
This issue can be reproduced on latest Flame 2.2&3.0 and N5 2.2&3.0 build, the ellipsis is at the left of an LTR phone label in new contact view.
Could you have someone to help with this bug? Many thanks!
Device information:
Flame 2.2 Build ID: 20150526162504
Flame 3.0 Build ID: 20150526160204
Nexus5 2.2 Build ID: 20150526162504
Nexus5 3.0 Build ID: 20150526160204
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Flags: needinfo?(whsu)

Comment 5

3 years ago
(In reply to Elie from comment #4)
> Hi William,
> This issue can be reproduced on latest Flame 2.2&3.0 and N5 2.2&3.0 build,
> the ellipsis is at the left of an LTR phone label in new contact view.
> Could you have someone to help with this bug? Many thanks!

@ Elie, thank you.
  Dylan had triaged it. Let's wait for solution.

@ All, I know that it is hard to handle the characters on the text field.
  But, I would like to tell you that function shortens the wording form the left side if you input LTR languages.
  It seems to be a unfriendly design.
  e.g. Birthday ---> ...thday.
Flags: needinfo?(whsu)
Created attachment 8646111 [details]
AriesKK_v2.5.png

This issue can be reproduced on latest AriesKK v2.5 build.
STR:
1.Set your phone language to Arabic.
2.Launch Contacts.
3.New a contact with a long LTR label for its phone number.
**The ellipsis is at the left of an LTR phone label.

See attachment:AriesKK_v2.5.png.
Reproducing rate:10/10

Device:AriesKK v2.5 build
Build ID               20150810003528
Gaia Revision          09dea2d5ff21cdb56da35fe4aa5bf4c90cf1da7f
Gaia Date              2015-08-09 17:11:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0e269a1f1beb
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150810.000017
Firmware Date          Mon Aug 10 00:00:24 UTC 2015
Bootloader             s1
Blocks: 1181926
This issue still can be reproduced on latest AriesKK&FlameKK v2.5 build.
Device info:
FlameKK v2.5 (512mb) Build ID: 20151028150209
AriesKK v2.5 Build ID: 20151029010303
Whiteboard: [2.5-rtl-test-run]

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.