test_dialer_find_contact.py: "IndexError: list index out of range"

RESOLVED FIXED

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: onelson, Assigned: martijn.martijn)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 fixed, b2g-master fixed)

Details

()

Attachments

(2 attachments, 2 obsolete attachments)

Reporter

Description

4 years ago
Error observed this morning:
http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1/144/HTML_Report/

Jenkins adhoc of all errors observed today (0/5 pass for this):
http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/771/HTML_Report/

Traceback (most recent call last):
  File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/.env/local/lib/python2.7/site-packages/marionette_client-0.9-py2.7.egg/marionette/marionette_test.py", line 290, in run
    testMethod()
  File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/tests/python/gaia-ui-tests/gaiatest/tests/functional/dialer/test_dialer_find_contact.py", line 52, in test_dialer_find_contact
    self.assertEqual(number_to_verify, call_screen.calling_contact_information.split(', ')[1])
IndexError: list index out of range


Seems odd that the phone may be dialing it's own number, at least from what I can tell locally on my end. From Dialer, test begins typing the number, dropdown appears to which the test taps to autocomplete. After dialer number has been filled, call begins and shortly after the test fails.
Assignee

Comment 1

4 years ago
After updating my build on the phone, I can also reproduce this.
It used to work with:
mozversion application_buildid: 20150404010205
mozversion application_changeset: 90adc073cbc6

It fails with:
mozversion application_buildid: 20150407010204
mozversion application_changeset: ab0490972e1e

http://mxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/tests/functional/dialer/test_dialer_find_contact.py
Reporter

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?] → [QAnalyst-Triage+][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
Assignee

Updated

4 years ago
Assignee: nobody → martijn.martijn
Assignee

Comment 3

4 years ago
Comment on attachment 8590795 [details] [review]
[gaia] mwargers:test_dialer_find_contact.py.diff > mozilla-b2g:master

Something changed in the call_screen.calling_contact_information format, apparently.
Just use the same assertIn check as in:
http://mxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/tests/functional/contacts/test_call_contact.py#40
It's more robust.
Attachment #8590795 - Flags: review?(npark)
Attachment #8590795 - Flags: review?(jlorenzo)
Comment on attachment 8590795 [details] [review]
[gaia] mwargers:test_dialer_find_contact.py.diff > mozilla-b2g:master

I do it this way too, avoiding hassle when they change the format a little. LGTM
Attachment #8590795 - Flags: review?(npark) → review+
Comment on attachment 8590795 [details] [review]
[gaia] mwargers:test_dialer_find_contact.py.diff > mozilla-b2g:master

Nice and simple! It'll make the error clearer. Thanks!
Attachment #8590795 - Flags: review?(jlorenzo) → review+
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Hi Martijn,
This case is also failed in today's 2.2 build.
Build ID               20150412002502
Gaia Revision          cec00d643f517ffd96cde559cd3bbd43ab85816c
Gaia Date              2015-04-10 21:41:12
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5005522fd68e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2

Can you help to uplift this fix to 2.2?
Flags: needinfo?(martijn.martijn)
Assignee

Comment 9

4 years ago
Comment on attachment 8591666 [details] [review]
[gaia] mwargers:test_dialer_find_contact.py_v22.diff > mozilla-b2g:v2.2

(In reply to Gerry Chang [:cfchang] from comment #7)
> Can you help to uplift this fix to 2.2?

I created the pull request.

I haven't tested it, myself, but I see no reason why this shouldn't work.
Flags: needinfo?(martijn.martijn)
Attachment #8591666 - Flags: review?(gchang)
Comment on attachment 8591666 [details] [review]
[gaia] mwargers:test_dialer_find_contact.py_v22.diff > mozilla-b2g:v2.2

I've tested it without issues. You can uplift to 2.2.
Attachment #8591666 - Flags: review?(gchang) → review+
Assignee

Comment 11

4 years ago
(In reply to Gerry Chang [:cfchang] from comment #10)
> Comment on attachment 8591666 [details] [review]
> [gaia] mwargers:test_dialer_find_contact.py_v22.diff > mozilla-b2g:v2.2
> 
> I've tested it without issues. You can uplift to 2.2.

The problem is that v2.2 Gip Treeherder Try runs are still busted. Normally, we can only merge with a green try run.
We need to be info from James Lal (or somebody else) if it would be ok to land this on v2.2 (and also other v2.2 pull requests) without a proper Treeherder Try run for v2.2.
Flags: needinfo?(jlal)
Flags: needinfo?(gchang)
OK. I don't have any questions about that.
Flags: needinfo?(gchang)
I am not going to give a go or no go on 2.2 greenness... Can you dig into what fails and why?
Flags: needinfo?(jlal) → needinfo?(martijn.martijn)
Assignee

Comment 14

4 years ago
(In reply to James Lal [:lightsofapollo] (pto back april 20) from comment #13)
> I am not going to give a go or no go on 2.2 greenness... Can you dig into
> what fails and why?

This was a Gaia UI test failure that I fixed on master, but it also started failing on v2.2, so it needs to be fixed there, too.

Or are you talking about why the Treeherder Try is busted for v2.2? I don't know why that's happening, but I know that all the fixes that landed on master and not on v2.2 certainly made things worse.
Flags: needinfo?(martijn.martijn) → needinfo?(jlal)
Assignee

Updated

4 years ago
Blocks: 1155747
Flags: needinfo?(jlal)
Assignee

Comment 15

4 years ago
Gerry, it looks like Treeherder try for v2.2 is green now, so we might be able to get the v2.2 pull request merged in. Can you or someone else drive this?
Or perhaps it was already checked in somehow?
Flags: needinfo?(gchang)
Hi Martijn,
The pull request is created by you, I don't have permission to do this. I think you can merge this or do you want me to create another pull request for this?
Flags: needinfo?(gchang) → needinfo?(martijn.martijn)
Assignee

Comment 17

4 years ago
(In reply to Gerry Chang [:cfchang] from comment #16)
> Hi Martijn,
> The pull request is created by you, I don't have permission to do this. I
> think you can merge this or do you want me to create another pull request
> for this?

We still need a green Treeherder Try run for this pull request, something I wasn't able to get with closing and reopening Treeherder Try for the said pull request (even though the change doesn't impact b2g desktop tests at all, btw).
So I guess we need a new pull request on the latest updated v2.2 tree, anyway. If you could do that, that would be great.
Flags: needinfo?(martijn.martijn)
Assignee

Comment 20

4 years ago
Comment on attachment 8605064 [details] [review]
[gaia] gerrycfchang:v2.2 > mozilla-b2g:v2.2

Gerry Chang said in this pull request: Please ignore this pull request.
Attachment #8605064 - Attachment is obsolete: true
Assignee

Updated

4 years ago
Attachment #8591666 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.