Unicode 6.3 Bidi Support - Add new Bidi classes and update character data.

RESOLVED FIXED in Firefox 40

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: tedders1, Assigned: tedders1)

Tracking

(Blocks 1 bug)

unspecified
mozilla40
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox38 wontfix, firefox39 wontfix, firefox40 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

4 years ago
Unicode 6.3 adds five new control characters for Bidi support (LRI, RLI, FSI, PDI, and ALM). There are also four new Bidi Class values that correspond to the first four characters (LRI, RLI, FSI, PDI).

We need to:

* Add the new Bidi classes to our code.

* Regenerate the character data.
(Assignee)

Updated

4 years ago
Assignee: nobody → tclancy
Blocks: 922963
(Assignee)

Comment 1

4 years ago
Attachment #8589266 - Flags: review?(smontagu)
(Assignee)

Updated

4 years ago
Blocks: 1152074
(Assignee)

Comment 2

4 years ago
Hi Simon,

Even though I'll be porting changes from ICU as much as possible, this particular patch will still be needed. Please review it when you have a moment.
Flags: needinfo?(smontagu)
(Assignee)

Comment 3

4 years ago
Attachment #8589266 - Attachment is obsolete: true
Attachment #8589266 - Flags: review?(smontagu)
Attachment #8594087 - Flags: review?(smontagu)
Comment on attachment 8594087 [details] [diff] [review]
bug-1151908-bidi-classes.patch

Review of attachment 8594087 [details] [diff] [review]:
-----------------------------------------------------------------

Sure
Attachment #8594087 - Flags: review?(smontagu) → review+
(Assignee)

Updated

4 years ago
Flags: needinfo?(smontagu)
Keywords: checkin-needed
Whiteboard: [systemsfe]
https://hg.mozilla.org/mozilla-central/rev/5abaed77e385
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
(Assignee)

Comment 8

4 years ago
This is needed for Bug 1166203, which is a confirmed blocker for 2.2.
blocking-b2g: --- → 2.2?
(Assignee)

Updated

4 years ago
Blocks: 1166203
(Assignee)

Comment 9

4 years ago
Comment on attachment 8594087 [details] [diff] [review]
bug-1151908-bidi-classes.patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
RTL support for B2G (Bug 906270)

This patch is required for Bug 1166203, which is confirmed as blocking 2.2. (And probably a bunch of similar issues which haven't been spotted yet.)

User impact if declined: 
Punctuation marks will appear in the wrong place when LTR phrases appear within RTL text, or vice versa.

Testing completed: 
Green treeherder run - https://hg.mozilla.org/mozilla-central/rev/5abaed77e385

Risk to taking this patch (and alternatives if risky): 
None forseen.

String or UUID changes made by this patch:
None.
Attachment #8594087 - Flags: approval-mozilla-b2g37?
(Assignee)

Updated

4 years ago
Attachment #8594087 - Flags: approval-mozilla-b2g37?
(Assignee)

Comment 10

4 years ago
Comment on attachment 8594087 [details] [diff] [review]
bug-1151908-bidi-classes.patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
RTL support for B2G (Bug 906270)

This patch is required for Bug 1166203, which is confirmed as blocking 2.2. (And probably a bunch of similar issues which haven't been spotted yet.)

User impact if declined: 
Punctuation marks will appear in the wrong place when LTR phrases appear within RTL text, or vice versa.

Testing completed: 
Green treeherder run - https://treeherder.mozilla.org/#/jobs?repo=try&revision=5cc35d2a9d2e

Risk to taking this patch (and alternatives if risky): 
None forseen.

String or UUID changes made by this patch:
None.
Attachment #8594087 - Flags: approval-mozilla-b2g37?
blocking-b2g: 2.2? → 2.2+

Updated

4 years ago
Attachment #8594087 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Hi Ryan,

This is the first bug. Next one is bug 1157726
You need to log in before you can comment on or make changes to this bug.