Getting faulty "requested profile directory missing" error when the profile dir does exist

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: erikvold, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

When I create a directory at `/mnt/sdcard/jetpack-profile` and start Fennec with it via `adb shell am start -a android.activity.MAIN -n org.mozilla.fennec/.App --es args "--profile /mnt/sdcard/jetpack-profile"`, then using `adb logcat` I see this error:

W/GeckoProfile(21328): requested profile directory missing: /mnt/sdcard/jetpack-profile"
V/GeckoProfile(21328): Fetching profile: 'default', '/mnt/sdcard/jetpack-profile"'
D/dalvikvm(21328): GC_CONCURRENT freed 129K, 7% free 3109K/3340K, paused 2ms+3ms, total 22ms
V/GeckoProfile(21328): Fetching profile: '', 'null'

I know that the folder does exist so this error, which comes from https://dxr.mozilla.org/mozilla-central/source/mobile/android/base/GeckoProfile.java#211 is just wrong.

I expect now to see an error saying that a folder does not exist when it does exist..
I have a node script which creates the profile dir mentioned, and tries to run firefox with this profile, producing the error mention described, here https://github.com/erikvold/jpm-mobile/tree/ea3045ad183d1e1f0a0428be7cbfe03603924620

To reproduce do this:
* git checkout git@github.com:erikvold/jpm-mobile.git
* cd jpm-mobile
* git checkout ea3045ad183d1e1f0a0428be7cbfe03603924620
* cd ..
* mkdir test-addon && cd test-addon
* jpm init
* node ./bin/jpm-mobile run --adb /path/to/adb

Note you need git, adb, jpm installed and an android device with the latest nightly installed plugged in to the desktop via usb for the above steps.
This looks due to bug 896109 which had no tests.
It looks like there's a double-quote (") character attached to the intended directory name: 

jetpack-profile"
(In reply to Erik Vold [:erikvold] (please needinfo? me) from comment #1)
> I have a node script which creates the profile dir mentioned, and tries to
> run firefox with this profile, producing the error mention described, here
> https://github.com/erikvold/jpm-mobile/tree/
> ea3045ad183d1e1f0a0428be7cbfe03603924620
> 
> To reproduce do this:
> * git checkout git@github.com:erikvold/jpm-mobile.git
> * cd jpm-mobile

Also need to do:

* npm install here!

> * git checkout ea3045ad183d1e1f0a0428be7cbfe03603924620
> * cd ..
> * mkdir test-addon && cd test-addon
> * jpm init
> * node ./bin/jpm-mobile run --adb /path/to/adb

This should be:

* node ../jpm-mobile/bin/jpm-mobile run --adb /path/to/adb
(In reply to Geoff Brown [:gbrown] from comment #3)
> It looks like there's a double-quote (") character attached to the intended
> directory name: 
> 
> jetpack-profile"

ahhhhh, thank you so much!

user error! :)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.