Closed Bug 1151974 Opened 5 years ago Closed 5 years ago

Intermittent test_controller.html,test_importscript.html,test_match_all.html,test_match_all_advanced.html,test_match_all_client_id.html,test_unregister.html | Some test failed with error Error: Error: Failed to load script (nsresult = 0x80004005)

Categories

(Core :: DOM: Workers, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox38 --- unaffected
firefox39 --- unaffected
firefox40 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: RyanVM, Assigned: bkelly)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files, 2 obsolete files)

02:19:58 INFO - 101 INFO TEST-START | dom/workers/test/serviceworkers/test_controller.html
02:19:58 INFO - 102 INFO TEST-UNEXPECTED-FAIL | dom/workers/test/serviceworkers/test_controller.html | Some test failed with error Error: Error: Failed to load script (nsresult = 0x80004005) - expected PASS
02:19:58 INFO - 103 INFO TEST-OK | dom/workers/test/serviceworkers/test_controller.html | took 3152ms
Blocks: 931249
Flags: needinfo?(nsm.nikhil)
OS: Android → All
Hardware: ARM → All
Summary: Intermittent test_controller.html | Some test failed with error Error: Error: Failed to load script (nsresult = 0x80004005) → Intermittent test_controller.html,test_importscript.html,test_match_all_client_id.html | Some test failed with error Error: Error: Failed to load script (nsresult = 0x80004005)
Duplicate of this bug: 1152215
Summary: Intermittent test_controller.html,test_importscript.html,test_match_all_client_id.html | Some test failed with error Error: Error: Failed to load script (nsresult = 0x80004005) → Intermittent test_controller.html,test_importscript.html,test_match_all_client_id.html,test_unregister.html | Some test failed with error Error: Error: Failed to load script (nsresult = 0x80004005)
Summary: Intermittent test_controller.html,test_importscript.html,test_match_all_client_id.html,test_unregister.html | Some test failed with error Error: Error: Failed to load script (nsresult = 0x80004005) → Intermittent test_controller.html,test_importscript.html,test_match_all.html,test_match_all_client_id.html,test_unregister.html | Some test failed with error Error: Error: Failed to load script (nsresult = 0x80004005)
Summary: Intermittent test_controller.html,test_importscript.html,test_match_all.html,test_match_all_client_id.html,test_unregister.html | Some test failed with error Error: Error: Failed to load script (nsresult = 0x80004005) → Intermittent test_controller.html,test_importscript.html,test_match_all.html,test_match_all_advanced.html,test_match_all_client_id.html,test_unregister.html | Some test failed with error Error: Error: Failed to load script (nsresult = 0x80004005)
This is Cache failing on PRAGMA incremental_vacuum.
Assignee: nobody → bkelly
Status: NEW → ASSIGNED
Flags: needinfo?(nsm.nikhil)
This is likely due to a closing Context holding a connection open while a new Context is spinning up.  We need to ensure this doesn't happen.
See Also: → 1112469
Ben, please remove this line once you landed the fix for this bug: <https://hg.mozilla.org/integration/mozilla-inbound/rev/bdfca48c0862#l1.34>.  Thanks!
This patch will prevent a delay Context initialization if there is a previous Context for the same origin in the process of closing.

I *think* this will resolve the problems we are seeing here, but I need try to prove it.  I'll do a bunch of retriggers here:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=ed6c32627d20
Attachment #8594156 - Flags: review?(ehsan)
Attachment #8594156 - Flags: review?(ehsan)
Updated patch that handles the case where Context::Start() is called after the Context has been cancelled.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=97442cdb9cf6
Attachment #8594156 - Attachment is obsolete: true
Attachment #8594170 - Flags: review?(ehsan)
Sorry, I didn't get to do this review today...
No problem.  Try shows I missed queuing Actions when in the new PREINIT state.  I'll roll a new patch.
The tests we care about look good in that try.  Lots of other orange due to pushing on inbound I think, though.

Here's an m-c try push:

  https://treeherder.mozilla.org/#/jobs?repo=try&revision=5c1ef35f326c
Attachment #8594266 - Flags: review?(ehsan)
Attachment #8594266 - Flags: review?(ehsan) → review+
Attachment #8594764 - Flags: review?(ehsan) → review+
https://hg.mozilla.org/mozilla-central/rev/590e7b0165b0
https://hg.mozilla.org/mozilla-central/rev/ea122f2cab01
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
Comment 66 and comment 67 seem to be unrelated failures.
Duplicate of this bug: 1153470
Duplicate of this bug: 1154205
Duplicate of this bug: 1154398
You need to log in before you can comment on or make changes to this bug.