crash in android::SkipCutBuffer::read(char*, unsigned int)

RESOLVED WORKSFORME

Status

Firefox OS
GonkIntegration
--
critical
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

({crash})

unspecified
All
Gonk (Firefox OS)
crash

Firefox Tracking Flags

(b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.1S affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [b2g-crash], crash signature)

This bug was filed from the Socorro interface and is 
report bp-ca1981cf-a406-491b-8ec8-3201e2150402.
=============================================================
Frame 	Module 	Signature 	Source
0 	libc.so 	libc.so@0x221a2 	
1 	libstagefright.so 	android::SkipCutBuffer::read(char*, unsigned int) 	/builds/slave/b2g_m-b32_20_flm-kk_ntly-00000/build/bionic/libc/include/../include/string.h:108
2 	libstagefright.so 	android::SkipCutBuffer::submit(android::MediaBuffer*) 	/builds/slave/b2g_m-b32_20_flm-kk_ntly-00000/build/frameworks/av/media/libstagefright/SkipCutBuffer.cpp:64
3 	libstagefright.so 	android::OMXCodec::read(android::MediaBuffer**, android::MediaSource::ReadOptions const*) 	/builds/slave/b2g_m-b32_20_flm-kk_ntly-00000/build/frameworks/av/media/libstagefright/OMXCodec.cpp:4245
4 	libxul.so 	android::OmxDecoder::ReadAudio(MPAPI::AudioFrame*, long long) 	dom/media/omx/OmxDecoder.cpp
5 	libxul.so 	mozilla::MediaOmxReader::DecodeAudioData() 	dom/media/omx/MediaOmxReader.cpp
6 	libxul.so 	mozilla::MediaDecoderReader::RequestAudioData() 	dom/media/MediaDecoderReader.cpp
7 	libxul.so 	mozilla::detail::MethodCallWithNoArgs<mozilla::MediaPromise<nsRefPtr<mozilla::AudioData>, mozilla::MediaDecoderReader::NotDecodedReason, true>, mozilla::MediaDecoderReader>::Invoke() 	dom/media/MediaPromise.h
8 	libxul.so 	mozilla::detail::ProxyRunnable<mozilla::MediaPromise<nsRefPtr<mozilla::AudioData>, mozilla::MediaDecoderReader::NotDecodedReason, true> >::Run() 	dom/media/MediaPromise.h
9 	libxul.so 	mozilla::MediaTaskQueue::Runner::Run() 	dom/media/MediaTaskQueue.cpp
10 	libxul.so 	nsThreadPool::Run() 	xpcom/threads/nsThreadPool.cpp
11 	libxul.so 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp
12 	libxul.so 	NS_ProcessNextEvent(nsIThread*, bool) 	xpcom/glue/nsThreadUtils.cpp
13 	libxul.so 	mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
14 	libxul.so 	MessageLoop::RunInternal() 	ipc/chromium/src/base/message_loop.cc
15 	libxul.so 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
16 	libxul.so 	nsThread::ThreadFunc(void*) 	xpcom/threads/nsThread.cpp
17 	libnss3.so 	_pt_root 	nsprpub/pr/src/pthreads/ptthread.c
18 	libc.so 	__thread_entry 	/builds/slave/b2g_m-cen_flm-kk_ntly-00000000/build/bionic/libc/bionic/pthread_create.cpp:105
19 	libc.so 	pthread_create 	/builds/slave/b2g_m-cen_flm-kk_ntly-00000000/build/bionic/libc/bionic/pthread_create.cpp:224 

Looks like a gonk integration issue?

Happens on : 
 	https://m.facebook.com/openwebapp/manifest.webapp
 	http://m.leparisien.fr/ 

On Flame, as well as Aries
More reports: 
https://crash-stats.mozilla.com/report/list?product=B2G&signature=android%3A%3ASkipCutBuffer%3A%3Aread%28char*%2C+unsigned+int%29
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
status-b2g-v2.0M: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.1S: --- → affected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Keywords: steps-wanted
This issue hasn't occurred since 4/10 so I flashed to the nightly build from that day to try and reproduce but I wasn't able to.  I spent a lot of time in Gallery/Music/Video since it seemed to be related to OMX Codec.  

Since this hasn't occurred in two months, maybe this one should be closed until/if it happens again?

Environmental Variables:
Device: Flame 3.0
BuildID: 20150410010202
Gaia: e768af6558957ddb0f6a9ce579ea41c3e3d0b203
Gecko: fec90cbfbaad
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #0)
> Happens on : 
>  	https://m.facebook.com/openwebapp/manifest.webapp
>  	http://m.leparisien.fr/ 

Does that mean the bug reproduces on these two links? I tried and couldn't repro. The first link the Flame doesn't know how to open it and gave me options to keep it or delete it, and the 2nd link I browsed on the website for a while and it LMK'ed which is pretty much expected on current 3.0 with 319MB memory.

Other than that I wasn't able to reproduce any kind of crash while browsing the web, using Gallery and Video app.

Device: Flame (full flashed, 319MB, KK)
BuildID: 20150624160209
Gaia: eb0d4aefa62b20420d6fa0642515a110daca5d97
Gecko: 7b0df70e27ea
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 41.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
Need info Naoki for the questions in Comment 3.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker) → needinfo?(nhirata.bugzilla)
This crash hasn't happened since 37 and the last time it has happened is on build: 20150608162505

https://crash-stats.mozilla.com/report/list?product=B2G&range_unit=days&range_value=28&signature=android%3A%3ASkipCutBuffer%3A%3Aread%28char*%2C+unsigned+int%29#tab-reports

Probably because of the LMK.  I think it may have gotten fixed by other patches.  Closing off as WFM, removing steps-wanted.

I think another process to add in the steps-wanted for crashes is to verify that the crashes are still occurring first.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(nhirata.bugzilla) → needinfo?(ktucker)
Keywords: steps-wanted
Resolution: --- → WORKSFORME
Whiteboard: [b2g-crash]
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.