'Learn more about DRM' context menu only working on click, not on enter or when accesskey pressed

RESOLVED FIXED in Firefox 38

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: aryx, Assigned: Gijs)

Tracking

Trunk
Firefox 40
Points:
1
Bug Flags:
firefox-backlog +
in-testsuite -
qe-verify -

Firefox Tracking Flags

(firefox38+ fixed, firefox39 fixed, firefox40 fixed)

Details

Attachments

(1 attachment)

Firefox Nightly 20150407 and Beta 20150406174117

The 'Learn more about DRM' context menu only works when clicked, not when the user presses Enter or when the accesskey gets pressed (the context menu only closes for these)

browser-context.inc contains more elements with onclick handlers but these seem to work for enter and accesskey presses (e.g. 'View Image').
(Assignee)

Comment 1

4 years ago
I don't really understand why this would be any different than the other onclick items which, as you noted, do work... however, time-constraint-wise maybe the best thing to do is to "just" add an extra oncommand listener and be done with (assuming that fixes things...).
status-firefox38: --- → affected
status-firefox39: --- → affected
tracking-firefox38: --- → ?
(Assignee)

Comment 2

4 years ago
Actually, looks to me like the other items with onclick handlers have oncommand or command attributes as well, so we should probably do the same.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
(Assignee)

Comment 3

4 years ago
Created attachment 8589670 [details] [diff] [review]
use command event and delegate clicks to it,
Attachment #8589670 - Flags: review?(jaws)
(Assignee)

Updated

4 years ago
Iteration: --- → 40.1 - 13 Apr
Points: --- → 1
Flags: qe-verify-
Flags: in-testsuite-
Flags: firefox-backlog+
OS: Windows 8.1 → All
Hardware: x86 → All
This feature is going to get some exposition. Tracking to make sure it is fixed before the release.
tracking-firefox38: ? → +
(Assignee)

Comment 5

4 years ago
remote:   https://treeherder.mozilla.org/#/jobs?repo=try&revision=59eb132707b0
Keywords: checkin-needed
(Assignee)

Comment 6

4 years ago
remote:   https://hg.mozilla.org/integration/fx-team/rev/f610b8d267ed
Keywords: checkin-needed
(Assignee)

Comment 7

4 years ago
Comment on attachment 8589670 [details] [diff] [review]
use command event and delegate clicks to it,

Approval Request Comment
[Feature/regressing bug #]: bug 1111147
[User impact if declined]: can't use keyboard to interact with the 'Learn More about DRM' item
[Describe test coverage new/current, TreeHerder]: nope :-(
[Risks and why]:  very low, simple attribute change to bring the item in line with existing menuitems
[String/UUID change made/needed]: nope
Attachment #8589670 - Flags: approval-mozilla-beta?
Attachment #8589670 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/f610b8d267ed
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-firefox40: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1140386
Comment on attachment 8589670 [details] [diff] [review]
use command event and delegate clicks to it,

Should be in 38 beta 4
Attachment #8589670 - Flags: approval-mozilla-beta?
Attachment #8589670 - Flags: approval-mozilla-beta+
Attachment #8589670 - Flags: approval-mozilla-aurora?
Attachment #8589670 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.