merging libnkcache.so with libnecko.so improves startup time

VERIFIED FIXED in mozilla1.2beta

Status

()

defect
P2
minor
VERIFIED FIXED
18 years ago
5 years ago

People

(Reporter: darin.moz, Assigned: alecf)

Tracking

({embed, perf})

Trunk
mozilla1.2beta
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix in hand)

Attachments

(1 attachment, 3 obsolete attachments)

Reporter

Description

18 years ago
merging nkcache module with necko module improves startup time

on an optimized linux build, i noticed about a 0.8% startup improvement after
merging libnkcache.so with libnecko.so.

there's no real reason to keep the cache in a separate dll.  it was originally
intended to be part of the core necko module, and only started out as a separate
module to simplify development.
Reporter

Comment 1

18 years ago

Updated

18 years ago
Blocks: 7251
Keywords: perf
Reporter

Updated

18 years ago
No longer blocks: 7251
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla0.9.8
Reporter

Updated

18 years ago
Blocks: 7251
Cool. Remember to:
a) Update all platform makefiles
b) Update package list to remove nkcache.dll
c) Send mail to people building dep to remove nkcache.dll from components/ or
just clobber build

Current changes look ok.
Reporter

Comment 3

18 years ago
-> 0.9.9
Target Milestone: mozilla0.9.8 → mozilla0.9.9
Reporter

Updated

18 years ago
Severity: normal → minor
Priority: P3 → P4
Reporter

Updated

18 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0
Reporter

Comment 4

18 years ago
-> 1.0

Comment 5

18 years ago
Moving Netscape owned 0.9.9 and 1.0 bugs that don't have an nsbeta1, nsbeta1+,
topembed, topembed+, Mozilla0.9.9+ or Mozilla1.0+ keyword.  Please send any
questions or feedback about this to adt@netscape.com.  You can search for
"Moving bugs not scheduled for a project" to quickly delete this bugmail.
Target Milestone: mozilla1.0 → mozilla1.2
Reporter

Updated

17 years ago
Target Milestone: mozilla1.2alpha → ---
Reporter

Comment 6

17 years ago
mass futuring of untargeted bugs
Target Milestone: --- → Future
Assignee

Updated

17 years ago
Blocks: 163737
Reporter

Comment 7

17 years ago
-> moz 1.2
Target Milestone: Future → mozilla1.2beta
Assignee

Comment 8

17 years ago
taking this, I'll have a complete fix (With mac support) relatively soon...
Assignee: darin → alecf
Status: ASSIGNED → NEW
Assignee

Updated

17 years ago
Priority: P4 → P2
Assignee

Comment 9

17 years ago
Posted patch cleaned up patch (obsolete) — Splinter Review
I decided to just start from scratch. I'm keeping nkcache as a seperate
"module" for now, I don't see any harm and it allows us to be more explicit
about our dependencies. 

I'll do the mac project stuff and the packager stuff when either bug 168048 or
bug 169003 gets reviewed & checked in (they are poluting both my trees at the
moment)
Attachment #61719 - Attachment is obsolete: true
Reporter

Updated

17 years ago
Attachment #99456 - Flags: superreview+
Reporter

Comment 10

17 years ago
Comment on attachment 99456 [details] [diff] [review]
cleaned up patch

r/sr=darin (looks good to me)
Assignee

Comment 11

17 years ago
Posted patch mac project changes (obsolete) — Splinter Review
here are the mac project changes to merge nkcache into necko - the patch looks
more complicated than it is because CW decided to be stupid when it exported
the file.
Comment on attachment 99456 [details] [diff] [review]
cleaned up patch

r=dougt
Attachment #99456 - Flags: review+
Comment on attachment 99847 [details] [diff] [review]
mac project changes

r=dougt
Attachment #99847 - Flags: review+
Assignee

Comment 14

17 years ago
on the other hand, I could just combine it all into one patch and include
packaging changes. Reviews? TIA..
Attachment #99456 - Attachment is obsolete: true
Attachment #99847 - Attachment is obsolete: true
Assignee

Updated

17 years ago
Status: NEW → ASSIGNED
Whiteboard: fix in hand
Assignee

Comment 15

17 years ago
Comment on attachment 99851 [details] [diff] [review]
combined patch

oh, doug already gave his review. Then I'm transferring over sr=darin, r=dougt
if nobody objects..
Attachment #99851 - Flags: superreview+
Attachment #99851 - Flags: review+
Assignee

Comment 16

17 years ago
and now its fixed.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Reporter

Comment 17

17 years ago
thanks alec!!

Comment 18

17 years ago
verified - confirmed patch checked in
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.