[RTL][Homescreen]The ellipsis will display at left side of screenshot path.

RESOLVED DUPLICATE of bug 1152230

Status

defect
P2
normal
RESOLVED DUPLICATE of bug 1152230
4 years ago
4 years ago

People

(Reporter: yulan.zhu, Assigned: mikehenrty)

Tracking

(Depends on 1 bug)

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
[1.Description]:
[RTL][v2.2&v3.0][Homescreen]Take a screenshot on lockscreen view, the ellipsis will display at left side of screenshot path. 
See attachment:Screenshot_ellipsis.png

[2.Testing Steps]: 
1.Set your phone language to Arabic.
2.Press power key twice to enter lockscreen view.
3.Take a screenshot and observe the lockscreen view.
4.Tap the notification in lockscreen view and observe the notification.

[3.Expected Result]: 
3&4.The ellipsis should be displayed at righe side of screenshot path.

[4.Actual Result]: 
3.&4.The ellipsis will display at left side of screenshot path.

[5.Reproduction build]: 
Flame 2.2 build(Affected):
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.195227
Firmware Date          Tue Apr  7 19:52:39 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (Affected):
Build ID               20150407160201
Gaia Revision          84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gaia Date              2015-04-07 17:33:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/078128c2600a
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.193600
Firmware Date          Tue Apr  7 19:36:12 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
15381
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact]
Triage: P2 -- see also Bug 1152230
Priority: -- → P2
Nominating. As per Julien's comment in Bug 1152230, yet another manifestation of bug 883884
blocking-b2g: --- → 2.2?
Whiteboard: MGSEI-RTL-3F → MGSEI-RTL-3F, [systemsfe]
blocking-b2g: 2.2? → 2.2+

Updated

4 years ago
Flags: needinfo?(kgrandon)
blocking-b2g: 2.2+ → ---
Assignee: nobody → mhenretty
Looks like Mike is on this one. Thanks!
Flags: needinfo?(kgrandon)
Posted image 2015-04-09-14-18-21.png (obsolete) —
Hi Lancy, from my initial testing I was able to see that this is a regression. Can you please get a regression window?
Flags: needinfo?(yulan.zhu)
Comment on attachment 8590480 [details]
2015-04-09-14-18-21.png

Sorry wrong screenshot here. I'm confused because with a build from last week and following the STRs, I don't get the same screenshot than posted here.
going to post a new screenshot now
Attachment #8590480 - Attachment is obsolete: true
Here is the correct screenshot, showing no issue last week

I tried with Pvt build from April 2nd
/pvt/mozilla.org/b2gotoro/nightly/mozilla-b2g37_v2_2-flame-kk/2015/04/2015-04-02-00-25-00
gaia revision="1ceca464053dee4a8bf10ea5abeef724d68c2ff2"
gecko revision="3720699f0df685f03360bf532baddb9a92a8ba5f"
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1152230
I have found the b2g-inbound regression window by the STR in comment 0:

Last Working Environmental Variables:
Device: Flame
Build ID               20150216100352
Gaia Revision          137948ea0e036305b007b40d26aa57de4b1737e8
Gaia Date              2015-02-16 17:31:32
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/0a5cb4590638
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  65
Firmware Date          Mon Dec 15 18:51:29 CST 2014
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame
Build ID               20150216151829
Gaia Revision          05d976da7c1ae4a4ae31ec794259d588e89529df
Gaia Date              2015-02-16 22:48:29
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/d2ecb69c49c2
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  65
Firmware Date          Mon Dec 15 18:51:29 CST 2014
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia: 05d976da7c1ae4a4ae31ec794259d588e89529df
Gecko: 0a5cb4590638

First Broken Gecko & Last Working Gaia - issue does NOT repro
Gaia: 137948ea0e036305b007b40d26aa57de4b1737e8
Gecko: d2ecb69c49c2
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Flags: needinfo?(yulan.zhu)

Comment 9

4 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15381/
Flags: in-moztrap+
QA Whiteboard: [rtl-impact][MGSEI-Triage+] → [rtl-impact][MGSEI-Triage+]MGSEI-RTL-3F
Whiteboard: MGSEI-RTL-3F, [systemsfe] → [systemsfe]
You need to log in before you can comment on or make changes to this bug.