[RTL][Notifications]The name of screenshot is displayed wrongly on notification in test device.

VERIFIED FIXED in Firefox OS v2.2

Status

P1
normal
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: yulan.zhu, Assigned: iliu)

Tracking

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(6 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
[1.Description]:
[RTL][v2.2&v3.0][Notifications]Enable BTand pair with another device, transfer screenshot from another device and recieve it in test device, the name of screenshot is displayed wrongly on notification in test device.
See attachment:Screenshot_notification.png

[2.Testing Steps]: 
1.Set your phone language to Arabic. 
2.Enable BTand paired with another device.
3.Send a screenshot to test device from another device via BT. 
4.Tap the notification.
5.Accept the transfer. 
6.Complete the transmission and observe the prompt in notifications. 

[3.Expected Result]: 
6.The file format of the screenshot should be displayed at right side of the name.

[4.Actual Result]: 
6.The file format of the screenshot is displayed at left side of the name.

[5.Reproduction build]: 
Flame 2.2 build(Affected):
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.195227
Firmware Date          Tue Apr  7 19:52:39 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (Affected):
Build ID               20150407160201
Gaia Revision          84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gaia Date              2015-04-07 17:33:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/078128c2600a
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.193600
Firmware Date          Tue Apr  7 19:36:12 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
15671
(Reporter)

Comment 1

4 years ago
Created attachment 8589525 [details]
Screenshot_notification.png
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
P1 -- nominating since screenshot name looks completely wrong (.png should not appear at left of word! Text should remain as in LTR here)
blocking-b2g: --- → 2.2?
Priority: -- → P1

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+
Take over the RTL issue.
Assignee: nobody → iliu
Status: NEW → ASSIGNED
Created attachment 8590744 [details]
2015-04-09-21-21-09.png

Hi Lancy, I cannot reproduce the issue with my locale production build. Could you please give more info for me? Thanks.
Flags: needinfo?(yulan.zhu)
I'm also unable to reproduce on today's 2.2 build.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Thanks for Dylan's re-check here.
(Reporter)

Comment 7

4 years ago
(In reply to Ian Liu [:ianliu] from comment #4)
> Created attachment 8590744 [details]
> 2015-04-09-21-21-09.png
> 
> Hi Lancy, I cannot reproduce the issue with my locale production build.
> Could you please give more info for me? Thanks.

Hi Ian Liu,

Send the screenshot with default name from another device to the test device, complete the transmission and observe the prompt in Notifications, you can see the name is shown wrong.
Refer to the video: Verify1_Notification.mp4.
Please contact me if you have any questions.

This issue still exist on the latest Flame 2.2 and Flame 3.0 build.

Flame 2.2 build(Affected):
Build ID               20150412002502
Gaia Revision          cec00d643f517ffd96cde559cd3bbd43ab85816c
Gaia Date              2015-04-10 21:41:12
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5005522fd68e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150412.040730
Firmware Date          Sun Apr 12 04:07:41 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build(Affected):
Build ID               20150412160203
Gaia Revision          3c68964cb9fdba7cf0f6829b7f44562acaf1f1d7
Gaia Date              2015-04-10 14:38:19
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0a46652bd992
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150412.192808
Firmware Date          Sun Apr 12 19:28:21 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(yulan.zhu) → needinfo?(iliu)
(Reporter)

Comment 8

4 years ago
Created attachment 8591457 [details]
Verify1_Notification.mp4
Thanks. Per Lancy's verification in comment 7, reopen the issue.
Status: RESOLVED → REOPENED
Flags: needinfo?(iliu)
Resolution: WORKSFORME → ---
(Assignee)

Updated

4 years ago
Status: REOPENED → ASSIGNED
Looks like the issue is relative with the default file name of screen shot. And the syntax make the text to be RTL.
Created attachment 8592072 [details] [review]
[gaia] ian-liu:notification/bug1152227_support_bi_direction_text_in_message_detail > mozilla-b2g:master
Comment on attachment 8592072 [details] [review]
[gaia] ian-liu:notification/bug1152227_support_bi_direction_text_in_message_detail > mozilla-b2g:master

Hi Zibi,

I see you work on Bug 1137593. The patch here is a little bit relative with Bug 1137593. But the root cause is supporting bi-direction text in the message detail of notification. Could you please help to review my patch? Thanks.
Attachment #8592072 - Flags: review?(gandalf)
Comment on attachment 8592072 [details] [review]
[gaia] ian-liu:notification/bug1152227_support_bi_direction_text_in_message_detail > mozilla-b2g:master

Since it's a 2.2+ blocking issue, I nominate Alive to be the reviewer to improve reviewing process.

Alive, could you please help to review my pull request? Thanks.
Attachment #8592072 - Flags: review?(alive)
Hi Ian, I left you a comment in the PR.
Zibi, I have updated the patch with your suggestion.
Comment on attachment 8592072 [details] [review]
[gaia] ian-liu:notification/bug1152227_support_bi_direction_text_in_message_detail > mozilla-b2g:master

Deliver review to Michael.
Attachment #8592072 - Flags: review?(alive) → review?(mhenretty)
Comment on attachment 8592072 [details] [review]
[gaia] ian-liu:notification/bug1152227_support_bi_direction_text_in_message_detail > mozilla-b2g:master

r+ on the toaster detail part.

The notification message part we should no longer need now that bug 1152230 landed. I believe the utility tray part is fixed on master now. If you still need to modify notifications.js in some way though, please reflag me.
Attachment #8592072 - Flags: review?(mhenretty) → review+
I don't think you need to change anything in notifications.js. Left a comment in PR
Update the patch without notifications.js changed. And I do manual test with the patch rebased. The notification message part is displayed normally now. Wait Zibi's final reviewing process. Thanks.
Attachment #8592072 - Flags: review?(gandalf) → review+
Since the patch is landed, we can close the issue now.

Gaia/master: https://github.com/mozilla-b2g/gaia/commit/3be562701d5b276ff2ac46a5e9fbd63a9b378d4d
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago4 years ago
status-b2g-master: affected → fixed
Resolution: --- → FIXED
Comment on attachment 8592072 [details] [review]
[gaia] ian-liu:notification/bug1152227_support_bi_direction_text_in_message_detail > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Support RTL
[User impact] if declined: The file name of notification toast is not normal in RTL.
[Testing completed]: Manual test
[Risk to taking this patch] (and alternatives if risky): Very low
[String changes made]: None
Attachment #8592072 - Flags: approval-gaia-v2.2?

Comment 22

4 years ago
Created attachment 8595785 [details]
v3.0_verified_pass.png

This issue has been verified passed on latest build of Flame 3.0 with the same steps in comment 0.
See attachment:v3.0_verified_pass.png
Rate:0/5

Device: Flame 3.0 (pass)
Build ID               20150421160203
Gaia Revision          15134b080b5f406e5aa36f5136c17dafb4e31f64
Gaia Date              2015-04-21 19:52:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/86725d1a2cf3
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.192130
Firmware Date          Tue Apr 21 19:21:42 EDT 2015
Bootloader             L1TC000118D0

Updated

4 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
status-b2g-master: fixed → verified

Updated

4 years ago
Attachment #8595785 - Attachment is obsolete: true

Comment 23

4 years ago
Created attachment 8595832 [details]
v3.0_verified_pass.png

Updated

4 years ago
Attachment #8592072 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/27d7c751f474f379cc2d2d328509c30c6b4cf5a8
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S11 (1may)

Comment 25

4 years ago
Created attachment 8597064 [details]
verified_pass.png

This issue has been verified passed on latest build of Flame 2.2 and Nexus_5 2.2/3.0 with the same steps in comment 0.
See attachment:verified_pass.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150423162502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5fe76b26e55f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.195827
Firmware Date          Thu Apr 23 19:58:39 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (pass)
Build ID               20150423002502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150423.035409
Firmware Date          Thu Apr 23 03:54:27 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (pass)
Build ID               20150423160207
Gaia Revision          0c5e2ee1173f3c53379ef3cd10de714836258fe8
Gaia Date              2015-04-23 16:10:10
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/22a157f7feb7
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150423.192918
Firmware Date          Thu Apr 23 19:29:36 EDT 2015
Bootloader             HHZ12f

Updated

4 years ago
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
QA Whiteboard: [rtl-impact][MGSEI-Triage+] → [rtl-impact][MGSEI-Triage+][MGSEI-RTL-3F]
Whiteboard: MGSEI-RTL-3F
You need to log in before you can comment on or make changes to this bug.