[RTL][CustomDialog]The file name will be mirrored in the transfer dialog box.

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
P1
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: yulan.zhu, Assigned: iliu)

Tracking

({late-l10n})

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

[1.Description]:
[RTL][v2.2&v3.0][Notifications]Transfer screenshot from another device to test device, the file name will be mirrored in the transfer dialog box.
See attachment:Screenshot_file name.png

[2.Testing Steps]: 
1.Set your phone language to Arabic. 
2.Enable BTand paired with another device.
3.Send a screenshot to test device from another device via BT. 
4.Tap the notification.

[3.Expected Result]: 
4.The file name should not be mirrored.

[4.Actual Result]: 
4.The file name will be mirrored.

[5.Reproduction build]: 
Flame 2.2 build(Affected):
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.195227
Firmware Date          Tue Apr  7 19:52:39 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (Affected):
Build ID               20150407160201
Gaia Revision          84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gaia Date              2015-04-07 17:33:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/078128c2600a
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.193600
Firmware Date          Tue Apr  7 19:36:12 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
15671
QA Whiteboard: [rtl-impact]
P1 -- nominating. Should not appear this way, conveys wrong meaning and creates confusion
blocking-b2g: --- → 2.2?
Is this also related to Bug 883884?
Priority: -- → P1
blocking-b2g: 2.2? → 2.2+
Hi Aaron,
Can you help to find someone from BT team who can fix this? Thanks!
Flags: needinfo?(awu)
Take over the RTL issue.
Assignee: nobody → iliu
Flags: needinfo?(awu)
Status: NEW → ASSIGNED
Summary: [RTL][Notifications]The file name will be mirrored in the transfer dialog box. → [RTL][CustomDialog]The file name will be mirrored in the transfer dialog box.
Comment on attachment 8590727 [details] [review]
[gaia] ian-liu:bluetooth/bug1152232_rtl_bdi_devicename_filename_filesize_for_fileTransfer_cofirmation_dialog > mozilla-b2g:master

Alive, could you please help to review my pull request? It's relative with Bi-directional text. Thanks.
Attachment #8590727 - Flags: review?(alive)
Keywords: late-l10n
Comment on attachment 8590727 [details] [review]
[gaia] ian-liu:bluetooth/bug1152232_rtl_bdi_devicename_filename_filesize_for_fileTransfer_cofirmation_dialog > mozilla-b2g:master

(do we need l10n folk feedback? I guess not.)
Attachment #8590727 - Flags: review?(alive) → review+
I have done manual test via production build with locales.ar.

https://github.com/mozilla-b2g/gaia/commit/b4c3fa000c11b215a3c5c893733774a932e7f0d5
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8590727 [details] [review]
[gaia] ian-liu:bluetooth/bug1152232_rtl_bdi_devicename_filename_filesize_for_fileTransfer_cofirmation_dialog > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Support RTL.
[User impact] if declined: Abnormal display on the confirmation dialog.
[Testing completed]: Manual test with production build/locales.ar.
[Risk to taking this patch] (and alternatives if risky): None.
[String changes made]: wantToReceiveFile --> wantToReceiveFile.innerHTML
Attachment #8590727 - Flags: approval-gaia-v2.2?
This is breaking string freeze. But given the issue was filed recently as well and nominated by :delphine, to see if this breakage for this particular case is fine from the l10n side?
Flags: needinfo?(lebedel.delphine)
Yeah, I think that the issue is bad enough that it needs to get fixed and we should get this in. Thanks!
Flags: needinfo?(lebedel.delphine)
Attachment #8590727 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue has been verified successfully on latest build of Flame 2.2/3.0 with the same steps in comment 0.
See attachment:correct_file_name.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150415162504
Gaia Revision          89a94a8b9c9087da916751697a61ba15bc0688c3
Gaia Date              2015-04-15 20:05:38
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20e92b626530
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150415.201243
Firmware Date          Wed Apr 15 20:12:52 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (pass)
Build ID               20150415160205
Gaia Revision          777d01f4a2c7b41c4b02e3cf87715714ccc0590b
Gaia Date              2015-04-15 17:20:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/53ceefb0e1c8
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150415.192055
Firmware Date          Wed Apr 15 19:21:04 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
QA Whiteboard: [rtl-impact][MGSEI-Triage+] → [rtl-impact][MGSEI-Triage+][MGSEI-RTL-3F]
Whiteboard: MGSEI-RTL-3F
You need to log in before you can comment on or make changes to this bug.