Gonk PlatformDecoderModule is broken.

RESOLVED FIXED in Firefox 40

Status

()

Core
Audio/Video: Playback
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: alfredo, Assigned: alfredo)

Tracking

(Blocks: 1 bug)

unspecified
mozilla40
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(firefox40 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Enable Gonk PlatformDEcoderModule and play a mp4 file from browser. It fails to play.

04-08 05:36:18.096 I/PRLog   ( 2900): 2015-04-08 09:36:18.109155 UTC - -1199926664[b1dd5900]: MP4Reader(b1520800)::void mozilla::MP4Reader::Update(mozilla::MP4Reader::TrackType): Update(Video) ni=1 no=1 iex=0 fl=0
04-08 05:36:18.096 I/PRLog   ( 2900): 2015-04-08 09:36:18.112842 UTC - -1199922576[afac9880]: MP4Reader(b1520800)::void mozilla::MP4Reader::ScheduleUpdate(mozilla::MP4Reader::TrackType): SchedulingUpdate(Video)
04-08 05:36:18.096 I/PRLog   ( 2900): 2015-04-08 09:36:18.112918 UTC - -1199926664[b1dd5900]: MP4Reader(b1520800)::void mozilla::MP4Reader::Update(mozilla::MP4Reader::TrackType): Update(Video) ni=1 no=1 iex=0 fl=0
04-08 05:36:18.106 I/PRLog   ( 2900): 2015-04-08 09:36:18.116729 UTC - -1199922576[afac9880]: MP4Reader(b1520800)::void mozilla::MP4Reader::ScheduleUpdate(mozilla::MP4Reader::TrackType): SchedulingUpdate(Video)
04-08 05:36:18.106 I/PRLog   ( 2900): 2015-04-08 09:36:18.116824 UTC - -1199926664[b1dd5900]: MP4Reader(b1520800)::void mozilla::MP4Reader::Update(mozilla::MP4Reader::TrackType): Update(Video) ni=1 no=1 iex=0 fl=0
04-08 05:36:18.106 I/PRLog   ( 2900): 2015-04-08 09:36:18.124219 UTC - -1199922576[afac9880]: MP4Reader(b1520800)::void mozilla::MP4Reader::ScheduleUpdate(mozilla::MP4Reader::TrackType): SchedulingUpdate(Video)
04-08 05:36:18.106 I/PRLog   ( 2900): 2015-04-08 09:36:18.124337 UTC - -1199926664[b1dd5900]: MP4Reader(b1520800)::void mozilla::MP4Reader::Update(mozilla::MP4Reader::TrackType): Update(Video) ni=1 no=1 iex=0 fl=0
04-08 05:36:18.116 E/OMX-VDEC-1080P(  200):
04-08 05:36:18.116 E/OMX-VDEC-1080P(  200): ERROR: Sending OMX_EventError to Client
04-08 05:36:18.116 E/ACodec  ( 2900): [OMX.qcom.video.decoder.avc] ERROR(0x80001009)
04-08 05:36:18.116 E/MediaCodec( 2900): Codec reported an error. (omx error 0x80001009, internalError -2147483648)
04-08 05:36:18.116 D/GonkVideoDecoderManager( 2900): Decoder failed, err=-38
04-08 05:36:18.116 D/GonkMediaDataDecoder( 2900): Failed to output data
04-08 05:36:18.116 D/GonkMediaDataDecoder( 2900): Callback error!


It looks like OMX video codec rejects the input sample.
is this a regression ?
Flags: needinfo?(ayang)
(Assignee)

Comment 2

3 years ago
I think so, it was ok at last week. I'm bisecting the changelist.
Flags: needinfo?(ayang)
(Assignee)

Comment 3

3 years ago
Bad news, 237908 is good, 237910 isn't.
(Assignee)

Comment 4

3 years ago
Created attachment 8590114 [details] [diff] [review]
use_annex_b_for_omx
(Assignee)

Updated

3 years ago
Attachment #8590114 - Flags: review?(jyavenard)
Comment on attachment 8590114 [details] [diff] [review]
use_annex_b_for_omx

Review of attachment 8590114 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry for that...
Attachment #8590114 - Flags: review?(jyavenard) → review+
(In reply to Alfredo Yang from comment #3)
> Bad news, 237908 is good, 237910 isn't.

Those revisions are unlikely going to be global... Should use the hash instead.
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
(Assignee)

Comment 7

3 years ago
One line changed on gonk kk so it won't break other platforms.
It won't break any testcase because try-run on emulator-kk doesn't work yet. :(
remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/59247aa975ee
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/59247aa975ee
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
(Assignee)

Comment 10

2 years ago
It happens again on m-c. :(
Not only MSE but also mp4 playback fails.

changeset:   256394:07befc6f54e7
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

2 years ago
Component: Audio/Video → Audio/Video: Playback
(Assignee)

Updated

2 years ago
Assignee: nobody → ayang
(Assignee)

Updated

2 years ago
Blocks: 1123246
(Assignee)

Comment 11

2 years ago
The problem is decoder enters dormant state because mOwner->IsHidden() is true.

https://dxr.mozilla.org/mozilla-central/source/dom/media/MediaDecoder.cpp#202
(Assignee)

Comment 12

2 years ago
It sets dormant to false later but mDecodingFrozenAtStateDecoding is true. That stops playback.

https://dxr.mozilla.org/mozilla-central/source/dom/media/MediaDecoderStateMachine.cpp#1507
(Assignee)

Comment 13

2 years ago
mQueuedSeek is not pending when returning from dormant state so the decoding won't start.
The root cause is different with this bug. I'll create another bug.

[1] https://dxr.mozilla.org/mozilla-central/rev/d6ea652c579992daa9041cc9718bb7c6abefbc91/dom/media/MediaDecoderStateMachine.cpp#1327
(Assignee)

Comment 14

2 years ago
Bug 1192694
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
No longer blocks: 1123246
You need to log in before you can comment on or make changes to this bug.