Print only print first and last page

VERIFIED FIXED in Firefox 38

Status

()

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: kinwolf, Assigned: mats)

Tracking

({regression, testcase})

37 Branch
mozilla40
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox37 wontfix, firefox38+ verified, firefox39+ verified, firefox38.0.5 fixed, firefox40+ verified, firefox-esr31 unaffected)

Details

Attachments

(2 attachments)

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150326190726

Steps to reproduce:

Go to http://blogs.msdn.com/b/powershell/archive/2014/01/31/want-to-secure-credentials-in-windows-powershell-desired-state-configuration.aspx
Try to print the page using the menu->print icon




Actual results:

Only the first and last page appear in the preview, and only those will print


Expected results:

There is at least 5 pages to print, not 2.  Even doing a "select all" and
text continued...

Even doing a select all and try to print that will give the same result.  Chrome, Opera and Internet explorer doesn't have that problem, they print that page fine.  The problem also happen on Windows 7.  It also happened on a https page from university, but I can't provide credentials to check this one out, obviously.
Print Prewiew is wrong on my machine with FF37, but the print output (PDF Creator, XPS Writer) is OK (4 pages).
Print preview regressed:
good=2014-12-15
bad=2014-12-16
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f14dcd1c8c0b&tochange=b836016d82b5
Component: Untriaged → Print Preview
Product: Firefox → Core
[Tracking Requested - why for this release]: regressed since Firefox37
Keywords: testcase-wanted
OS: Windows Vista → All
Hardware: x86 → All
Posted file reduced html
Tracking for 38+ since this is a recent regression.
Summary: Print only print fist and last page → Print only print first and last page
Mats, can you help on this? Thanks
Flags: needinfo?(mats)
I don't have time to work on this for a while, so I think we should
just revert the change from bug 1108104 for now since this regression
is worse than what we were trying to fix there.  This patch also fixes
bug 1155230, although the problem there seems like a minor edge case.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=e88253b44292
Assignee: nobody → mats
Flags: needinfo?(mats)
Attachment #8594737 - Flags: review?(roc)
Blocks: 1155230
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/4555ae9718d1
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
Mats - From comment 9 I take it that you went with a backout. 38 and 39 are also affected. Can we backout from those branches as well?
Flags: needinfo?(mats)
Comment on attachment 8594737 [details] [diff] [review]
Revert the change from bug 1108104

Approval Request Comment
[Feature/regressing bug #]: bug 1108104
[User impact if declined]: missing content in Print/Preview
[Describe test coverage new/current, TreeHerder]: we have poor test coverage here, we should add the test in this bug and bug 1155230 as reftests [helpwanted]
[Risks and why]: low-risk, reverts to old behavior before bug 1108104
[String/UUID change made/needed]: none
Flags: needinfo?(mats)
Attachment #8594737 - Flags: approval-mozilla-beta?
Attachment #8594737 - Flags: approval-mozilla-aurora?
Comment on attachment 8594737 [details] [diff] [review]
Revert the change from bug 1108104

[Triage Comment]
38 is now in m-r!
Attachment #8594737 - Flags: approval-mozilla-release+
Attachment #8594737 - Flags: approval-mozilla-beta?
Attachment #8594737 - Flags: approval-mozilla-aurora?
Attachment #8594737 - Flags: approval-mozilla-aurora+
Should be in 38 beta 7
Flags: qe-verify+
Reproduced this issue on Firefox 37.0.2, build ID: 20150415140819.

Confirming the fix on Windows 7 64-bit, Ubuntu 14.04 32-bit and Mac OS X 10.9.5 using:
- latest Nightly, build ID: 20150426030248;
- latest Aurora, build ID: 20150426004003;
- Firefox 38 beta 8, build ID: 20150426174329.
Status: RESOLVED → VERIFIED
QA Contact: cornel.ionce
Duplicate of this bug: 1158804
Duplicate of this bug: 1159702
Verified on 40 Nightly, Aurora 39 and Beta 38 - removing qe-verify flag.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.