[Camera][SHB] Taking a picture from Camera via Share Activity (Contact Photo/Messages attachment) will ignore spacing to preview image

RESOLVED DUPLICATE of bug 1151562

Status

Firefox OS
Gaia::Contacts
RESOLVED DUPLICATE of bug 1151562
3 years ago
3 years ago

People

(Reporter: oliverthor, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], [SHB-enabled], [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8589752 [details]
shb_contactphoto_buttonspacing.png

Description:
When a user has software home button enabled and attempts to add a picture for a contact photo (via Camera), they will observe that the buttons will be pushed up against the photo preview. Normally these are centered along the bottom of the UI, with equal spacing both between the preview of the image (above) and the bottom of the phones screen (below). 
The SHB increases the distance to the bottom of the screen, but doesn't create more UI space for the buttons, thus pushing them up.

PreReq:
* Software Home Button enabled
Repro Steps:
1) Update a Flame to 20150408001204
2) Open the 'Contacts' app
3) Create/Edit a contact
4) Tap the big '+' to add a contact photo
5) Add from Camera
6) Take a picture
7) Observe Preview Image UI

Actual:
Buttons for "Accept" and "Retake" run along the bottom of the image preview, ignoring normal spacing.

Expected:
Buttons for "Accept" and "Retake" acknowledge new spacing for the SHB, equal to the SHB and to the image preview


Environmental Variables:
--------------------------------------------------

Device: Flame 3.0
BuildID: 20150408010203
Gaia: 84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gecko: 078128c2600a
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Device: Flame 2.2
BuildID: 20150408002503
Gaia: ea735c21bfb0d78333213ff0376fce1eac89ead6
Gecko: 43041c78052b
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

================================================= 
Issue DOES NOT REPRO on 2.1 for flame devices:
Results: Buttons for "Accept" and "Retake" acknowledge new spacing for the SHB, equal to the SHB and to the image preview

Device: Flame 2.1
Build ID: 20150408001204
Gaia: 87e55a7ec688138812181747f690fd188d2a0668
Gecko: 23214f805a5c
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

--------------------------------------------------

Repro frequency: 7/7
See attached: 
screenshot
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing], [SHB-enabled], [systemsfe]
(Reporter)

Comment 1

3 years ago
This issue is more widespread then initially logged, and occurs whenever a share activity is observed by Camera to take a picture. Changing the component to camera.

PreReq:
* Software Home button enabled
1) Open the Messages app
2) Create a new message
3) Add attachment -> from Camera
4) Take a picture
5) Observe Preview Image

Actual:
Buttons for "Accept" and "Retake" run along the bottom of the image preview, ignoring normal spacing.

Expected:
Buttons for "Accept" and "Retake" acknowledge new spacing for the SHB, equal to the SHB and to the image preview
Summary: [Contacts][SHB] Taking a contact photo from Camera will move buttons to accept to run along preview image → [Camera][SHB] Taking a picture from Camera via Share Activity (Contact Photo/Messages attachment) will ignore spacing to preview image
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Resolution: --- → DUPLICATE
Duplicate of bug: 1151562
You need to log in before you can comment on or make changes to this bug.