MMS data connection is never deactivated if MMS fails to send

RESOLVED FIXED in Firefox 40, Firefox OS v2.2

Status

Firefox OS
RIL
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: pgravel, Assigned: edgar)

Tracking

(Blocks: 1 bug)

unspecified
2.2 S10 (17apr)
x86
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox38 wontfix, firefox39 wontfix, firefox40 fixed, b2g-v1.4 unaffected, b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.1S affected, b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [caf priority: p2][CR 820234])

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
MmsService never tries to deactivates the MMS data call in some error cases, which results in the MMS data call remaining up forever.

The case that I was able to reproduce consistently is due to an error with ensureRouting (separate bug), in which case the MMS data call remain up forever because MmsService doesn't seem to do proper cleanup in some cases.

Snippet of log from when the failure occurs:
> I Gecko   : -@- MmsService: Got the MMS network connected! Resend the buffered MMS requests: number: 1
> I Gecko   : -@- MmsService: flushPendingCallbacks: 1 pending callbacks with status: 0
> I Gecko   : -@- MmsService: Failed to ensureRouting: Error: Failed to resolve 'proxy.mobile.att.net', with status: 2152398878
> I Gecko   : -@- MmsService: The sending status of sendTransaction.run(): -8
> I Gecko   : -@- MmsService: The returned status of sending transaction: aErrorCode: 4 aEnvelopeId: null
> I Gecko   : -@- MmsService: Marking the delivery state/staus is done. Notify sent or failed.
> I Gecko   : -@- MmsService: Sending MMS failed.
(Reporter)

Updated

3 years ago
blocking-b2g: --- → 2.2?

Comment 1

3 years ago
Edgar, can you please check this bug?
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(echen)
(Assignee)

Comment 2

3 years ago
(In reply to Ken Chang[:ken] from comment #1)
> Edgar, can you please check this bug?

Sure.
Assignee: nobody → echen
Flags: needinfo?(echen)
(Assignee)

Comment 3

3 years ago
Hi pgravel, is it possible to share full log to us for investigating? Thank you.
Flags: needinfo?(pgravel)

Updated

3 years ago
Whiteboard: [CR 820234]

Updated

3 years ago
Whiteboard: [CR 820234] → [caf priority: p2][CR 820234]
(Reporter)

Comment 4

3 years ago
Hi Edgar

The log I attached to bug 1152568 would serve as a valid log for this bug. But I don't think they would help much. The relevant point of failure is included in the description.

Basic scenario is:
1. data is down
2. try to send mms
3. mmsService call SetupDataCallByType('mms')
4. data is brought up
5. mms service is notified data is available, tries resolve mms proxy
6. proxy fails to resolve for some reason (in this case it's due to the problem you mentioned in bug 1152568)
7. due to failure, MmsService never calls DeactivateDataCallByType('mms')
Flags: needinfo?(pgravel)
(Assignee)

Comment 5

3 years ago
Created attachment 8590600 [details]
mms_fail.log

This log is from bug 1152568.
(Assignee)

Updated

3 years ago
Blocks: 1032097
(Assignee)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
(Assignee)

Updated

3 years ago
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → affected
status-b2g-v2.0M: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.1S: --- → affected
(Assignee)

Comment 6

3 years ago
Created attachment 8590668 [details] [diff] [review]
Patch, v1
(Assignee)

Comment 7

3 years ago
Comment on attachment 8590668 [details] [diff] [review]
Patch, v1

Review of attachment 8590668 [details] [diff] [review]:
-----------------------------------------------------------------

Hi Bevis, may I have your review for this patch? Thank you.
Attachment #8590668 - Flags: review?(btseng)
Comment on attachment 8590668 [details] [diff] [review]
Patch, v1

Review of attachment 8590668 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Thanks for having this quick fix.
Attachment #8590668 - Flags: review?(btseng) → review+
(Assignee)

Comment 9

3 years ago
Try result: https://treeherder.mozilla.org/#/jobs?repo=try&revision=f316d82ab6c1
(Assignee)

Comment 10

3 years ago
Created attachment 8591456 [details] [diff] [review]
Patch,v2, r=bevis

Rebase only.
Attachment #8590668 - Attachment is obsolete: true
Attachment #8591456 - Flags: review+
(Assignee)

Comment 11

3 years ago
https://hg.mozilla.org/integration/b2g-inbound/rev/fac9c1f3729b
https://hg.mozilla.org/mozilla-central/rev/fac9c1f3729b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S10 (17apr)

Comment 13

3 years ago
Comment on attachment 8591456 [details] [diff] [review]
Patch,v2, r=bevis

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch:
Flags: needinfo?(bbajaj)
Attachment #8591456 - Flags: approval-mozilla-b2g37?
(Assignee)

Comment 14

3 years ago
Comment on attachment 8591456 [details] [diff] [review]
Patch,v2, r=bevis

(In reply to Anshul from comment #13)
> Comment on attachment 8591456 [details] [diff] [review]
> Patch,v2, r=bevis
> 
> NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to
> better understand the B2G approval process and landings.
> 
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): 
> User impact if declined: 
> Testing completed: 
> Risk to taking this patch (and alternatives if risky): 
> String or UUID changes made by this patch:

v2.2 needs a rebased patch, I will attach it soon, and ask approval then.
Thank you, Anshul.
Attachment #8591456 - Flags: approval-mozilla-b2g37?
(Assignee)

Comment 15

3 years ago
Created attachment 8592070 [details] [diff] [review]
[b2g37_v2_2]  Patch, r=bevis

Patch for b2g37_v2_2.
(Assignee)

Comment 16

3 years ago
Comment on attachment 8592070 [details] [diff] [review]
[b2g37_v2_2]  Patch, r=bevis

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 1032097.
User impact if declined: MMS connection is never deactivated if MMS fails to send due to ensureRouting error.
Testing completed: Manually test.
Risk to taking this patch (and alternatives if risky): Low
String or UUID changes made by this patch: None.
Attachment #8592070 - Flags: approval-mozilla-b2g37?

Updated

3 years ago
Flags: needinfo?(bbajaj)
Attachment #8592070 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0697e47968a2
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
status-firefox38: --- → wontfix
status-firefox39: --- → wontfix
You need to log in before you can comment on or make changes to this bug.