[Nexus 5][Camera]HDR function is not supported in Camera

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Camera
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: SandKing, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [flame-l-testing-needed])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8590155 [details]
Bug picture: 2015-04-09-18-40-38.png

[1.Description]:
[Nexus 5][v2.2&3.0][Camera]There is no "HDR" item on Camera Options page.
See bug picture:"2015-04-09-18-40-38.png"
See refer picture:"Flame2.2.png"
See log:"logcat_1836.txt"
Found Time: 18:36

[2.Testing Steps]: 
1. Launch Camera.
2. Press "Menu" button.

[3.Expected Result]: 
2. It should have a  "HDR" item on Options page.

[4.Actual Result]: 
2. There is no "HDR" item on Options page.

[5.Reproduction build]: 
Nexus5 2.2(Affected)
Build ID               20150408162503
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9ab8a3ae0fc3
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150408.194901
Firmware Date          Wed Apr  8 19:49:15 EDT 2015
Bootloader             HHZ12d

Nexus5 3.0(Affected)
Build ID               20150408160203
Gaia Revision          a290b11627ec2b7c25980f5687a98da86641cfe4
Gaia Date              2015-04-08 08:26:08
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2c92a7df87c9
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150408.194541
Firmware Date          Wed Apr  8 19:45:58 EDT 2015
Bootloader             HHZ12d

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8590156 [details]
Refer picture: Flame2.2.png
(Reporter)

Comment 2

3 years ago
Created attachment 8590157 [details]
Bug log: logcat_1836.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
regressionwindow on v2.2, thanks.
status-b2g-v2.1: --- → unaffected
Keywords: regression, regressionwindow-wanted
Just confirmed that HDR appears correctly on Flame v2.2 (w/ memlimit of 1024MB):

Gaia-Rev        df0e04acad7c8c993f6ffe07b0ccb0ec20ee50bb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/091b1cc1240b
Build-ID        20150410002502
Version         37.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  65
FW-Date         Mon Dec 15 18:51:29 CST 2014
Bootloader      L1TC000118D0

Depending on the platform, HDR support can be exposed in different ways. Flame exposes HDR in KEY_SUPPORTED_SCENE_MODES; the Nexus 5L does not.
(Just looking through the source for the Nexus 5 L build -- I don't see any references to "HDR" in the camera code.)
I don't see HDR in Flame 2.2. Does this have something to do with memory settings? We always use 319MB.

I recall NOT seeing this option for a long time so I thought it was intentionally removed.
(In reply to Pi Wei Cheng [:piwei] from comment #6)

> I don't see HDR in Flame 2.2. Does this have something to do with memory
> settings? We always use 319MB.

That's correct: Flame w/ 319MB doesn't have enough memory to support HDR. You need to configure your device for at least 512MB (I used 1024MB) to enable HDR.
Thanks for the info. I'm adding keyword to exclude this in our queries since we don't have a Nexus 5 device and this bug is exclusive to it.
QA Whiteboard: [QAnalyst-Triage?], QAExclude
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?], QAExclude → [QAnalyst-Triage+], QAExclude
Flags: needinfo?(ktucker)

Comment 9

3 years ago
Hi Viral,
Could you help to check this issue? Is this related to build script?
Thanks!
Flags: needinfo?(vwang)

Comment 10

3 years ago
Hi Hayden,

Could you please help to check the HDR function in camera?
Thank you :)
Flags: needinfo?(vwang) → needinfo?(hahuang)
HDR function was exposed by Camera HAL as a scene mode in CameraParameters but this mode is removed from HAL3 (the one we used on Nexus 5 L) so we're not able to take HDR image anymore.

Hayden
Flags: needinfo?(hahuang)
Keywords: regressionwindow-wanted
Whiteboard: [flame-l-testing-needed]

Comment 12

3 years ago
Resolved as workforme per comment 11
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.