Closed Bug 1152715 Opened 9 years ago Closed 9 years ago

[Flame][Message]The original draft still exists even if you've discarded draft after editing it.

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.2 affected, b2g-master unaffected)

RESOLVED DUPLICATE of bug 1080504
Tracking Status
b2g-v2.2 --- affected
b2g-master --- unaffected

People

(Reporter: yue.zhou, Unassigned)

Details

Attachments

(2 files)

[1.Description]:
[Flame][v2.2][Message]The original draft still exists even if you've discarded draft after editing it.  And if you open the original draft again, it will be an empty draft.
Attachment: 430.mp4 and logcat_430.txt
Happen time: 4:30 PM

[2.Testing Steps]: 
1. Launch Browser, and then open a website
2. Tap Menu -> Share -> Message
3. Press Home key
** It will save the draft automatically.
4. Long Press Home key, select browser
** It keeps in compose message view
5. Type something in text field to make the message be different from the original draft
6. Tap "X" on top left, select Discard
7. Tap home key and launch Message, check if the draft still exists.

[3.Expected Result]: 
7. The original draft should be removed successfully if you select discard after editing this draft.

[4.Actual Result]: 
7. The original draft still exists even if you've discarded draft after editing it.  And if you open the original draft again, it will be an empty draft.

[5.Reproduction build]: 
Flame 2.2:   Affected
Build ID               20150408002503
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/43041c78052b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2

Flame 3.0:   Unaffected
Build ID               20150408160203
Gaia Revision          a290b11627ec2b7c25980f5687a98da86641cfe4
Gaia Date              2015-04-08 08:26:08
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2c92a7df87c9
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached video Bug video: 430.mp4
Thanks for filing this bug! Looks like a dupe of bug 1080504. It doesn't seem difficult to fix, but it's still unclear what to do in case the same draft is opened from activity and main app instance at the same time.

Boon, it should work correctly if you don't have main Messages app instance opened at the same (or close and reopen it once again), please feel free to reopen if it's not true.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.