[Flame][Settings]There is a white area above heading in Settings view.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Settings
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Elie, Unassigned)

Tracking

({polish})

unspecified
ARM
Gonk (Firefox OS)
polish

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
[1.Description]:
[Flame v2.2&3.0][Settings]View facebook profile when the wifi is off,tap Check settings to enter Settings view ,here is a white area above heading in Settings view.
Attchment:2015-04-08-22-30-44.png and logcat(13).txt
Happen time: 14:56

[2.Testing Steps]: 
1.Import some Facebook contacts
2.Disable wifi
3.Tap a facebook contact to view detail
4.Tap View facebook profile
5.Tap Check settings to enter Settings view 

[3.Expected Result]: 
5.There is no white area above heading in Settings view.

[4.Actual Result]: 
5.There is a white area above heading in Settings view.

[5.Reproduction build]: 
Flame 2.2: Affected
Build ID               20150408002503
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/43041c78052b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2

Flame 3.0:   Affected
Build ID               20150408160203
Gaia Revision          a290b11627ec2b7c25980f5687a98da86641cfe4
Gaia Date              2015-04-08 08:26:08
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2c92a7df87c9
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
(Reporter)

Comment 1

3 years ago
Created attachment 8590177 [details]
2015-04-08-22-30-44.png
(Reporter)

Comment 2

3 years ago
Created attachment 8590179 [details]
logcat(13).txt
Is this happening in other scenario when the checking connection page pops up?
Flags: needinfo?(zikui.yang)
Keywords: polish
(Reporter)

Comment 4

3 years ago
(In reply to Eric Chang [:ericcc] [:echang] from comment #3)
> Is this happening in other scenario when the checking connection page pops
> up?

Yes ,This issue also happening in other scenario 
scenario 1:
Import some Facebook contacts->Disable wifi->Tap a facebook contact to view detail->Tap "Messages(facebook)" or "Wall post"->Tap Check settings to enter Settings view 
>>This issue will happen.
scenario 2:
connect Wifi->launch contact->contact settings->Import Contacts->Tap "Gmail" or "Outlook"->Input username and PW->Turn off Wifi from unility tray and tap Login->Tap Check settings to enter Settings view 
>>This issue will happen.
Thanks.
Flags: needinfo?(zikui.yang) → needinfo?(echang)
In 2.1, the "View Facebook profile" is grayed out when without wifi/data connection, spec changed since v2.2?
Flags: needinfo?(echang) → needinfo?(cawang)
I think it's for bug 837924.
https://bugzilla.mozilla.org/show_bug.cgi?id=837924
I'll check the format of the pop-up page to see if it does follow building block. If not, I'll open another bug for the issue.

Meanwhile, the white area described in this bug is really a bug. It should be fixed. Thanks!
Flags: needinfo?(cawang)
FWD to Wesley for backlog.
Flags: needinfo?(whuang)
Will determine the priority during comms backlog grooming
tracking-b2g: --- → backlog
Component: Gaia::Settings → Gaia::Contacts
Flags: needinfo?(whuang)
Comms triage: Systemsfe issue.
Component: Gaia::Contacts → Gaia::Settings
Whiteboard: [systemsfe]

Comment 10

3 years ago
fixed in master
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.