[Messages] Empty report panel when opening it for an SMS that has been sent/received from a SIM that's not in the device anymore

RESOLVED FIXED

Status

Firefox OS
Gaia::SMS
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: julienw, Assigned: julienw)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [p=1])

Attachments

(3 attachments)

(Assignee)

Description

3 years ago
Created attachment 8590242 [details]
screenshot

Error message is:

04-09 14:51:22.767  3707  3707 W Messages: [JavaScript Error: "TypeError: iccManager.getIccById(...) is null" {file: "app://sms.gaiamobile.org/js/information.js" line: 152}]


Likely STR:
1. send a SMS using a SIM.
2. stop the phone, switch the SIM with another SIM
3. starts the some, open Messages app, open the previous thread
4. longpress the sent SMS, then choose "view report"

qawanted for a branch check
Created attachment 8590243 [details] [review]
[gaia] julienw:1152758-fix-report-panel-for-unknown-iccid > mozilla-b2g:master
(Assignee)

Comment 2

3 years ago
Comment on attachment 8590243 [details] [review]
[gaia] julienw:1152758-fix-report-panel-for-unknown-iccid > mozilla-b2g:master

A simple patch for a simple bug :)
Attachment #8590243 - Flags: review?(schung)
Looks like Julien is working on it :)
Assignee: nobody → felash
Status: NEW → ASSIGNED
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
I was unable to reproduce this issue on Flame 2.2 (Nightly user build, full flash & Tinderbox engineer build, shallow flash). The phone number of sender or receiver appeared correctly on the message report on both sent and received SMS. I tried with a different SIM in original SIM slot; different SIM in different SIM slot; original SIM in different SIM slot; no SIM in the device.

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150409002503
Gaia: ea735c21bfb0d78333213ff0376fce1eac89ead6
Gecko: 0efd5cdbe224
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.2 (KK, 319mb, shallow flash)
Build ID: 20150409102936
Gaia: 0bfb78bb850cd2f47e97a6107d2ace5d21efbac3
Gecko: cb3537ce1f8e
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Leaving qawanted for others to try.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
I was also unable to reproduce this issue on 2.2 Flame after about an hour of testing.  

Juilien is there possibly some other setup step required to reproduce this issue?  Maybe it is carrier specific to the reports or something?  We use AT&T here.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150409031135
Gaia: ea735c21bfb0d78333213ff0376fce1eac89ead6
Gecko: c4eae622b7bf
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(felash)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Assignee)

Comment 6

3 years ago
Thanks Jayme,

You're right, I think we need this setup too: have more than 2 SIMs on the device. So this needs to be in a DSDS setup.
Flags: needinfo?(felash)
Created attachment 8590677 [details]
no-info.png

Hi Jenny, after applying this patch, the via field will display with empty information if the message is sent by the sim that does not exist in slot currently. Do you think we should leave field empty or just hide the field if no information for display?
Attachment #8590677 - Flags: ui-review?(jelee)
There is another solution provided by Julien that we can have an "unknown sim" string for his field if we can't match any info. But it's not an option if it's 2.2 blocker since it's too late for having new string.
triage: edge case
blocking-b2g: 2.2? → -

Comment 10

3 years ago
Comment on attachment 8590677 [details]
no-info.png

Hi Steve,

Per discussion, it is preferred to show "Unknown SIM" as suggested by Julien in the Via field. If it's not possible at this stage, can we remove the line altogether (no title, no empty line)? thanks!
Attachment #8590677 - Flags: ui-review?(jelee) → ui-review-
(Assignee)

Comment 11

3 years ago
Because it's been minused I can do what I want :) Thanks Jenny !
Comment on attachment 8590243 [details] [review]
[gaia] julienw:1152758-fix-report-panel-for-unknown-iccid > mozilla-b2g:master

Since we'll need additional string for unknown sim information, unassign review and please request again once you finish it, thanks!
Attachment #8590243 - Flags: review?(schung)
(Assignee)

Updated

3 years ago
Blocks: 1156177
Whiteboard: [p=1]
(Assignee)

Comment 13

3 years ago
Comment on attachment 8590243 [details] [review]
[gaia] julienw:1152758-fix-report-panel-for-unknown-iccid > mozilla-b2g:master

Hey Steve,

I left more comments on github, tell me what you think !
Attachment #8590243 - Flags: review?(schung)
Comment on attachment 8590243 [details] [review]
[gaia] julienw:1152758-fix-report-panel-for-unknown-iccid > mozilla-b2g:master

Just a small nit and lgtm, thanks!
Attachment #8590243 - Flags: review?(schung) → review+
(Assignee)

Comment 15

3 years ago
As discussed on IRC, the nit won't be fixed. Let's land this :)
Keywords: qawanted → checkin-needed

Updated

3 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#IK4hOJssQO-NtOw1kRGCSw

The pull request failed to pass integration tests. It could not be landed, please try again.
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#a23Fr8jFSUauzBO87J8d2A

The pull request failed to pass integration tests. It could not be landed, please try again.
(Assignee)

Comment 18

3 years ago
manually merged because the previous try was completely green and the issues here seems to be unrelated.

master: af87ae8353d3825ce55edb54374e8efa9762e784
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.