[e10s] Scrollable popup doesn't stick around so can't scroll

RESOLVED DUPLICATE of bug 1049285

Status

()

defect
RESOLVED DUPLICATE of bug 1049285
4 years ago
4 years ago

People

(Reporter: milan, Assigned: gw280)

Tracking

({regression, reproducible})

39 Branch
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: [STR in comment #7])

Nightly, OS X, 10.9.5, reproducible close to 100% time.

While creating a new bug, click on the OS to change from OS X to, say All.  If you let go of the mouse in order to scroll, the popup disappears.  Autoscroll doesn't work, so the only way to do it is to click, move sideways to the scrollbar, then let go - the popup then stays up and you can scroll to the top and choose "All".
I don't see this with today's m-c nightly (testing on OS X 10.8.5).  Please try again with a clean profile.
I don't see this on OS X 10.7.5, 10.9.5 or 10.10.2 either (still testing with today's m-c nightly).

Please test with a clean profile, as I requested above.  And if you haven't rebooted your computer for longer than a day, please also try that.
10.9.5, clean profile, today's build, fresh boot this morning, creating new bug failed, opening a second tab, going to a random bug and clicking on the OS as the first interaction with the page, and it failed.
Not sure if relevant, but I do get a bunch of these in the log:
WARNING: Trying to paint an e10s popup in the child process!: file /Users/msreckovic/Repos/mozilla-central/widget/PuppetWidget.cpp, line 932
"creating new bug failed" above meant "trying the workflow where I'm creating a new bug failed to reproduce the problem".  Where the "it failed" means I reproduced the problem on an existing bug.
Definitely not a 100% success in reproducing it though.
> WARNING: Trying to paint an e10s popup in the child process!

So you're using a debug build?  I haven't been.

And where exactly did this warning appear?  In the system console (or in Terminal when running your build from a Terminal prompt)?  In the browser console?

This warning does sound quite relevant, though.
I now see this bug with both of today's m-c nightlies (the debug and "regular" one), using the following STR (which I find 100% effective);

1) Copy this bug's URL (https://bugzilla.mozilla.org/show_bug.cgi?id=1152807).
2) Open a new window (cmd-n).
3) Paste the URL into the new window's location bar and press Enter.
4) As your first action in the new window, click on "OS X" next to "Platform".
Keywords: reproducible
Whiteboard: [STR in comment #7]
(Following up comment #7)

Of course the new window needs to be an e10s window.
To answer comment 6, though some of it was answered in comment 7 - I first saw it in release, then decided to try in debug on the off chance that something useful shows up in the terminal/console.  The message mentioned was in the terminal.
I think this is expected in certain cases.. gw280, does this ring any bells? related to our select work and the feed ui problem maybe?
Flags: needinfo?(gwright)
Here's the regression range:

firefox-2015-03-13-03-02-31-mozilla-central
firefox-2015-03-14-03-02-39-mozilla-central

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=42afc7ef5ccb&tochange=38154607d807
Hmm, that has bug 1152807 in it, which specifically dealt with an odd event handling issue with popups. 

Steven, any chance you could back that out and test for me?
I had my eyes on that bug, too.

I'll do a bisect between that patch and the one that landed just before it.
(In reply to Jim Mathies [:jimm] from comment #12)
> Hmm, that has bug 1152807 in it, which specifically dealt with an odd event
> handling issue with popups. 
> 
> Steven, any chance you could back that out and test for me?

sorry - bug 1082510
possible dupe? bug 1058881
> sorry - bug 1082510

That's actually what I meant.  I somehow didn't see your wrong number :-)
Yes, the following patch is definitely the trigger for this bug:

 Bug 1082510 - When we detect a chrome popup at the current event coordinates and remote content has the mouse captured, release capture. r=Enn
author	Jim Mathies <jmathies@mozilla.com>
	Thu, 12 Mar 2015 14:32:20 -0500
changeset 233548	4f6461936cd2

http://hg.mozilla.org/mozilla-central/rev/4f6461936cd2
> possible dupe? bug 1058881

Could be.  But it doesn't give us any STR, or even hints at STR.  So there's nothing there to work with.

Updated

4 years ago
Flags: needinfo?(gwright)
Thanks for digging.
tracking-e10s: --- → ?
Keywords: regression
Summary: Scrollable popup doesn't stick around so can't scroll → [e10s] Scrollable popup doesn't stick around so can't scroll
Version: unspecified → 39 Branch
Had this happen on a popup that doesn't need scrolling (bugzilla needinfo from reporter/myself/other), in case that piece of information helps.
Assignee: nobody → gwright
I spoke to Milan and he hasn't seen this in a while. Without reliable STR, I suggest we shelve this for a while. Kicking back into triage.
I can't reproduce this.  The select box is working same as it does on release Firefox.
Status: NEW → ASSIGNED
tracking-fennec: --- → +
tracking-fennec: + → ---
Milan managed to reproduce this whilst I was sitting next to him. It's a dupe of bug 1049285.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1049285
You need to log in before you can comment on or make changes to this bug.