Closed Bug 1152811 Opened 4 years ago Closed 2 years ago

Investigate perma-orange crash on browser_pluginCrashReportNonDeterminism.js and re-enable

Categories

(Core :: Plug-ins, defect, P2)

x86
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
e10s + ---
firefox-esr52 --- wontfix
firefox57 --- wontfix
firefox58 --- fixed
firefox59 --- fixed

People

(Reporter: mconley, Assigned: gsvelto)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Attachments

(1 file)

Bug 1110887 introduced a new test to exercise our handling of some non-determinism with how the content and browser processes handle plugin process crashes.

That test seems to fail consistently on Linux when run in the suite. It seems that we hit a content process crash due to a MOZ_ABORT:

[Parent 22296] WARNING: '!aObserver', file /media/Projects/mozilla/mozilla-central/xpcom/ds/nsObserverService.cpp, line 287
[Child 22926] ###!!! ABORT: X_CreateGC: BadDrawable (invalid Pixmap or Window parameter); sync; id=0x4400008: file /media/Projects/mozilla/mozilla-central/toolkit/xre/nsX11ErrorHandler.cpp, line 157
#01: X11Error (/media/Projects/mozilla/mozilla-central/toolkit/xre/nsX11ErrorHandler.cpp:158)
[Child 22926] ###!!! ABORT: X_CreateGC: BadDrawable (invalid Pixmap or Window parameter); sync; id=0x4400008: file /media/Projects/mozilla/mozilla-central/toolkit/xre/nsX11ErrorHandler.cpp, line 157
Hit MOZ_CRASH() at /media/Projects/mozilla/mozilla-central/memory/mozalloc/mozalloc_abort.cpp:33

And here's a screenshot at the time of failure:

http://i.imgur.com/Tf7xbfb.png

I can reproduce this locally by running the test on a debug build with --run-until-failure. It only takes two or three repeats for the failure to rear its head.

We should figure out what's going on and re-enable the test.
Blocks: e10s-tests
tracking-e10s: --- → +
Let's start this off where the test lives, and if the issue is in another component we can always move it.
Component: General → Plug-ins
Product: Firefox → Core
Keywords: crash
Priority: -- → P2
I'm looking into this. I've run the tests locally together with other ones and it seems to be working again so maybe it's time to re-enable it.
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Comment on attachment 8929181 [details]
Bug 1152811 - Re-enable browser_pluginCrashReportNonDeterminism.js;

https://reviewboard.mozilla.org/r/200476/#review205612

Thanks!
Attachment #8929181 - Flags: review?(mconley) → review+
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/30022d08636e
Re-enable browser_pluginCrashReportNonDeterminism.js; r=mconley
https://hg.mozilla.org/mozilla-central/rev/30022d08636e
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Might as well land this on Beta too, I reckon.
Whiteboard: [checkin-needed-beta]
https://hg.mozilla.org/releases/mozilla-beta/rev/0d20053d0805
Flags: in-testsuite+
Whiteboard: [checkin-needed-beta]
You need to log in before you can comment on or make changes to this bug.