Closed Bug 1152852 Opened 5 years ago Closed 5 years ago

Notification sound for highlights in chats not played if chat tab is selected, even when Thunderbird is not the currently active/focused application (in background)

Categories

(Thunderbird :: Instant Messaging, defect)

x86
Windows 8.1
defect
Not set

Tracking

(thunderbird38+ fixed, thunderbird39 fixed, thunderbird40 fixed)

RESOLVED FIXED
Thunderbird 40.0
Tracking Status
thunderbird38 + fixed
thunderbird39 --- fixed
thunderbird40 --- fixed

People

(Reporter: aryx, Assigned: aryx)

Details

(Keywords: regression)

Attachments

(1 file)

Windows 8.1, Thunderbird 38 20150401012718

Reported by RyanVM, reproduced by me.

The notification sound for highlights in chats is not played if the chat tab is selected, even when Thunderbird is not the currently focused application, e.g. in background.

Regression from bug 961666?
Attached patch patch, v1Splinter Review
This is likely a regression by bug 1127802. https://hg.mozilla.org/comm-central/annotate/e2cdfef448c1/mail/components/im/modules/chatNotifications.jsm#l43 plays the sound when the chat tab is not the active tab.
Assignee: nobody → archaeopteryx
Status: NEW → ASSIGNED
Attachment #8590475 - Flags: review?(clokep)
Attachment #8590475 - Flags: review?(clokep) → review+
Unfortunately this is in TB 38. Maybe we should uplift?
https://hg.mozilla.org/comm-central/rev/1e8d5c907a77
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8590475 [details] [diff] [review]
patch, v1

[Approval Request Comment]
Regression caused by (bug #): bug 961666
User impact if declined: Chat highlights (somebody else typo one's name) won't get cause a sound notification if Thunderbird isn't the focused application but the Chat tab is the active tab.
Testing completed (on c-c, etc.): Tested locally
Risk to taking this patch (and alternatives if risky): low, only touches the code responsible for the sound notification
Attachment #8590475 - Flags: approval-comm-beta?
Attachment #8590475 - Flags: approval-comm-aurora?
Target Milestone: --- → Thunderbird 40.0
You need to log in before you can comment on or make changes to this bug.