hang after backspacing above pasted text

VERIFIED DUPLICATE of bug 114928

Status

SeaMonkey
Composer
--
critical
VERIFIED DUPLICATE of bug 114928
16 years ago
13 years ago

People

(Reporter: sujay, Assigned: Joe Francis)

Tracking

({hang})

Trunk
mozilla0.9.7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE [QAHP]; today, URL)

(Reporter)

Description

16 years ago
using 12/13 build of netscape on Win 98

1) Launch netscape
2) jump to above website that has text that you can Copy 
3) Copy several lines from the top onwards
4) launch composer
5) hit carriage return to get a couple blank lines
6) Paste
7) Now place the caret above the pasted line     <----must do this
8) hit backspace once/twice

hang.
(Reporter)

Updated

16 years ago
Whiteboard: EDITORBASE [QAHP]

Comment 1

16 years ago
I often do this after I paste in text and then try to reformat the text in the
compose window a bit.   I encountered this several times in "real world" usage
trying to compose an email message.
Keywords: hang

Updated

16 years ago
Severity: normal → critical

Comment 2

16 years ago
I can repro this on Mac OS X. Sampler tells me that we're in an infinite loop 
somewhere in code called from nsHTMLEditRules::MoveNodeSmart().

Comment 3

16 years ago
Rules code --> core
Assignee: syd → jfrancis

Comment 4

16 years ago
similar: bug 114890
(Reporter)

Comment 5

16 years ago
114890 is different.....this bug 115286 involves a hang, thus making the
product unusable after that point.

Comment 6

16 years ago
Reproducing again on Mac OSX using build 2001121004. What I'm noticing, however,
is not necessarily a hang, but Composer not actually deleting those lines. The
program is still responsive for me, I can manuever in navigator, I can even move
around in Composer. If you use the delete key, instead of the backspace key,
then it will properly delete the extra blank lines.
(Assignee)

Comment 7

16 years ago
Almost certainly same bug as 114928, but leaving seperate for now until I prove 
that.  097
Status: NEW → ASSIGNED
Whiteboard: EDITORBASE [QAHP] → EDITORBASE [QAHP]; today
Target Milestone: --- → mozilla0.9.7
(Assignee)

Comment 8

16 years ago
This is indeed a dup.  Attaching fix to 114928 shortly.

*** This bug has been marked as a duplicate of 114928 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

16 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.